URL:
  <http://gna.org/bugs/?21417>

                 Summary: Requirement 'present' / 'negated' field never sent
to client
                 Project: Freeciv
            Submitted by: jtn
            Submitted on: Thu Jan  2 19:59:38 2014
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: In Progress
             Assigned to: jtn
        Originator Email: 
             Open/Closed: Open
                 Release: 2.3.4,2.4.1
         Discussion Lock: Any
        Operating System: Any
         Planned Release: 

    _______________________________________________________

Details:

In send_ruleset_cache(), a requirement's 'negated' field (more recently
'present') is carefully fetched with req_get_values(), but then the value sent
to the client is always negated==FALSE (or present==TRUE).

It's been like this forever (r10499
<http://svn.gna.org/viewcvs/freeciv?revision=10499&view=revision>, PR#13049,
2005-05) -- prior to anywhere I can conveniently check rationale.

Any reason not to send the correct value to the client? I tried a smoke test
on trunk, and no smoke was emitted.




    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?21417>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to