Summary: Minimum gtk3 version to 3.8
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Mon 25 Aug 2014 03:11:10 AM EEST
                Category: bootstrap
                Priority: 5 - Normal
                  Status: Ready For Test
                 Privacy: Public
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: 2.6.0



- There's notable theming changes in gtk+ between 3.6 and 3.8. It might be a
burden to try to maintain compatibility with pre-3.8 theming as we work on
improving it (it's possible that we already depend on 3.8 in a way, themes not
working as well in older versions)
- Default client in 2.5 is gtk2, so the issue of people using gtk3-client
there and wanting to upgrade to freeciv-2.6 is not so critical. Anyway, even
gtk+-3.8 is an relatively old version by the time freeciv-2.6 comes out
(latest gtk+ is already 3.12)

Thus attached patch bumps minimum gtk3 requirement from 3.6 to 3.8. While it
doesn't magically break the code from working with 3.6, it makes us free not
to care about 3.6 compatibility. We should later check any constructs
deprecated in 3.8 in our codebase (we can't fix later deprecations as there
wouldn't be alternative way to do things in 3.8)


File Attachments:

Date: Mon 25 Aug 2014 03:11:10 AM EEST  Name: Gtk38.patch  Size: 3kB   By:



Reply to this item at:


  Message sent via/by Gna!

Freeciv-dev mailing list

Reply via email to