Update of bug #21038 (project freeciv):

                Severity:              3 - Normal => 4 - Important          
                  Status:                    None => Postponed              
                 Summary: Can't enter text with some CJK input methods =>
replace gtk+ DLLs with version >2.24.10 => Many GUI problems with CJK input
method => replace gtk2 DLLs with version >=2.24.14

    _______________________________________________________

Follow-up Comment #18:

Thanks for the research, taka! So these three disparate symptoms (1)-(3) have
a single root cause and fix, which looks like it went into Gtk+ 2.24.14 and
3.6.4.

(I'd missed that bug #22607 was previously reported here. Since the root cause
is the same, let's keep it all in this ticket.)

We're still stuck here as before: the latest available official Windows
package <http://www.gtk.org/download/win32.php> of Gtk2 is still 2.24.10. So
all of our Gtk2 builds are going to be broken unless we somehow change our
Gtk2 version.

The official Windows Gtk3 package is 3.6.4, which is supposedly fixed. Maybe
this is a reason we should sort out our Gtk3 builds to release quality?
Perhaps it'd be worth a CJK user checking whether our experimental Gtk3 builds
(2.4.3
<http://download.gna.org/freeciv/packages/windows/testing/Freeciv-2.4.3-win32-gtk3-setup.exe>
or 2.5.0-beta1
<http://download.gna.org/freeciv/packages/windows/testing/Freeciv-2.5.0-beta1-win32-gtk3-setup.exe>)
are generally better for CJK use?
(Beware that they have several other known bugs, see task #7760.)

----

(Re comment #9: I double-checked, and 2.4.1 was released with Gtk+ 2.24.10, so
should be affected by this bug.)

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?21038>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to