On Tue, Dec 27, 2016 at 6:16 PM, Jose Antonio Senna
<jasse...@vivointernetdiscada.com.br> wrote:
>  I booted FreeDOS kernel 2042 from a floppy in a W98SE machine, and it seems 
> to run OK.

Which one? You mean this one or a custom one?


>  It is unable to load Windows, that is, if I type
>  win
>  there appear the error messages
>  unimplemented internal dos function INT2F/1231
>  Registry file not found
>  XMS cache may be unavailable in this session
>  and Windows fails to start.
>  This is probably not new, as it has been said in other
> posts that FreeDOS is unable to load Windows 9X.  I don't
> know whether the above error messages the same found
> by other people.

Win95 was bundled with MS-DOS because it was exclusively meant to be
used with that DOS (and none other). It was allegedly for marketing,
not technical, reasons. So it doesn't, by default, intend or suppose
to work on other DOSes. There are undocumented behaviors that make it
much harder to work with other DOSes. Even DR-DOS (which could run Win
3.x with no problems) had some troubles, but eventually they
(privately) made fixes (and won a lawsuit against MS because of that,

So no, it's not reasonable to expect FreeDOS to work under a running
Win95. It may be possible in theory (if someone fixed the bugs), but
nobody has done it (yet, AFAIK). Not entirely sure, never tried, but
DOSBox may claim to support such a setup, though!

>  More worrying is that FreeDOS also fails to boot Linux.
>  I wrote a Wary Puppy live CD and tried to boot it from
> DOS prompt in the same machine, using loadlin.exe with
> the command line
>  loadlin .\vmlinuz initrd=.\initrd.gz acpi=off pfix=ram
>  MSDOS 7 (the native version in the machine) did boot
> Wary Puppy Linux without problem.

Dunno, doesn't MS load at a different segment (0x50 vs. 0x60) or such?

>  FreeDOS, however, did copy vmlinuz and initrd.gz to memory,
> then rebooted the computer.
>  My guess is that it has a broken (or none) warm boot handler.
>  In many cases the BIOS warm boot is not to be trusted
> in machines 1998 and later, for that method of going
> back from protected to real mode had then already fallen
> out of fashion.

Dunno, try Gujin (DOS version) instead, it should work (although I
likely only tried like once several years ago):


>  Another remark: Where is the DOSLFN driver ? I could not find
> it in ibiblio, and it seems that FreeDOS does not show long
> filenames by itself.
>  The HD filesystem was FAT32 in this test.

DOSLFN is here:

1). http://adoxa.altervista.org/doslfn/index.html

FreeCOM 0.84-pre2 XMS_Swap has LFN support and will show such files
only if you use "dir /lfn" (or put "/lfn" in %DIRCMD%", not to mention
"lfnfor on" and "lfnfor complete"). This disables DESCRIPT.ION (read)
support, however. 4DOS has some setting in its .INI file too, but I
forget offhand.

Keep in mind that not all DOS apps are LFN-aware or totally bugfree
(in case it wasn't obvious).

Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
Freedos-devel mailing list

Reply via email to