--- Begin Message ---
Kenneth J. Davis wrote:
charles wrote:
Been trying to install freedos V1.0 onto a SCSI HD. The fdisk program is giving me Invalid Drive Designation but will see the SCSI drives when I issue "set FFD_VERSION=6" at the command prompt. That doesn't do me any good though with xfdisk or format. System specs and SCSI specs and settings follows:


hmmm, this may invalidate what I said below, need to look into it more, but I still think your best bet is to ensure the SCSI controller's BIOS is set to enabled and not just Boot Only.

...

Support Removable Disks under BIOS as Fixed Disks = Boot Only

You need to change this setting

...
From these settings FreeDOS should see the drives a ordinary fixed disks. But it doesn't. Any help on this would be greatly appreciated.

I could be mistaken, but it is my impression this option as set only enables the SCSI BIOS if you are booting from the HD connected to the SCSI controller, otherwise it will be disabled. This is the key to getting FDISK to work, as it requires BIOS int13h support to see the drive. If the SCSI BIOS is disabled you would need to load an ASPI driver in combination with a DOS device driver to access the fixed disk, which even if loaded I am not certain that standard fdisk/format utilities will work with (depends on if they use DOS calls or BIOS calls).


Charles

P.S. Linux can access these drives just fine.

The drives are mostly likely there, just the Linux includes the needed drivers, whereas DOS does not, so you either need to load them or ensure BIOS support is available.

Jeremy
(ps my messages don't make it to the list, hence the CC)



Ok,

I did what was suggested here but still no go.

I think that you have this line:

Support Removable Disks under BIOS as Fixed Disks = Boot Only

confused with this line:

Host Adapter BIOS = Enabled

However I did change the previous option to see what happened.

I think that this option:

Extended BIOS Translation For DOS Drives > 1GByte = Enabled

switches between LBA and CHS modes. That would make sense anyway since CHS wasn't a problem before drives became larger than 1G.

This option:

BIOS Support For More Than 2 Drives (MS-DOS 5.0 and above) = Enabled

I think was to eliminate the need for DOS drivers when using more than 2 hard drives.

All permutations of these options gave the same result. So I tried loading the ASPI driver for it.

        devload aspi8dos.sys /D

It identified the drives and designated them C: and D:\

        Int 13H active for Drives: C: D:

        Int 13H routed through ASPI manager.
        ASPI8DOS.SYS installation successful.
        1 character device installed.
        Driver staying resident.

FreeDOS completely blows this off and refuses to access the drives installed using fdisk (Unless using the before mentioned set option) or xfdisk or format. Since aspi8dos.sys should have taken the BIOS out of the loop here.

I did check using a Windows 98 boot disk to see if the problem existed there after loading the ASPI driver but there wasn't any problem. So it sounds like a problem in FreeDOS regarding Int 13H.

Please tell me if I'm mistaken.


Charles


--- End Message ---
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Freedos-user mailing list
Freedos-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/freedos-user

Reply via email to