Hi Jan,

> I have tried a number of image files from different sources
> with the same result.
> I get a "FreeDos" message with a flashing cursor, and keyboard
> is ignored.

If I had to guess, I would say your CF has another (virtual) CHS
geometry set by the BIOS of your embedded system than the one
which is used while making the image (if you use one) or while
running SYS while the CF is plugged to another computer to make
the CF bootable (if you take that route).

Things you can do: Make sure both BIOSes use the same geometry
or make sure that CHS is disabled and only LBA is used. Or as
third option: Connect the CF to the system where it you will
later boot it, boot that system from diskette/CD/DVD/... and
then run SYS X: there (where X: is your CF boot partition).

When you install from Linux, you can use
to write a boot sector (just copy kernel and command com as if
they were normal files, sys-freedos-linux does not do that for
you). With that tool, you can also tweak some parameters like
the CHS geometry :-). Plus - only if you use FAT32 - you can
select whether you want CHS or rather LBA style booting.


This SF.net email is sponsored by the 2008 JavaOne(SM) Conference 
Don't miss this year's exciting event. There's still time to save $100. 
Use priority code J8TL2D2. 
Freedos-user mailing list

Reply via email to