Your problem is that that you're using a USB printer, rather than a
parallel port printer.  MS never added USB support to DOS, even though they
actually continued to make DOS for several years after USB came out
(mid-1990's).  No version of DOS today has "native" support for USB
(printers, mice, keyboards, etc.) -- not even FreeDOS.

There are only two possible solutions right now if you want to print to a
USB printer in "real" DOS (and not under a Windows "DOS Box" of some sort).
 I am working on DOS USB some drivers, but they are not in a finished state
yet and will only work on some computers (depends on the hardware).   My
web site is:


Georg Potthast also has also made some DOS USB drivers.  His will work on
more hardware than mine currently do, but are much more limited in their
functionality (and are not free).  His web site is:


There is also a Wiki page on DOS USB support, which has quite a bit of
useful information:


Sorry it isn't any easier than that, but unfortunately you'll need to do
some research and experimentation to find something that works for you.


  I tried using your programs, but for some reason they did not work. When
I loaded the usbprint app, I ran this command "usbprint status" and it said
on the bottom "no printer installed" when I clearly had the printer plugged
in. I also tried it where I loaded it and then plugged in the printer, but
it still said "no printer installed". Any help would do it! Thanks,

                                      --- A FreeDOS User
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and 
threat landscape has changed and how IT managers can respond. Discussions 
will include endpoint security, mobile security and the latest in malware 
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
Freedos-user mailing list

Reply via email to