On Mon, Mar 21, 2016 at 11:18 AM, Darryl Perry <dperry....@yahoo.com> wrote:
> I'm having an issue while running freedos 1.1 in a qemu VM on the Raspberry
> Pi B+
> I run qemu like this:
> qemu-system-i386 \
> -localtime \
> /home/bbs/doors/qemu/freedos.img \
> -boot c \
> -hdc fat:/home/bbs/text \
> -hdb fat:/home/bbs/temp${NODE} \
> -m 1024
> But when I run a program that tries to write to E: (hdc) drive, it gives me
> the following error:
> "PANIC more than two near fnodes requested at the same time!"
> Am I doing something wrong?  Any help would be appreciated.

I don't think "fat:" write support is as well-tested (officially, if
at all) vs. read-only support. I think it's just a QEMU limitation
(but I could be wrong).

7-Zip ("7z") these days can unpack various disk image formats
directly, so you may wish to just use that, if you need to extract
some files from guest to host. Or use some kind of networking (FTP

Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
Freedos-user mailing list

Reply via email to