Well, I'm adding more facts without adding much more understanding.

I removed the Realtek card and installed a 3Com PNP ISA network card instead. With a PS/2 mouse connected, it booted fine -- the ICU driver configured the 3Com and the mouse worked. So this seems to implicate the Realtek card.

Then I installed the Realtek in a different PC of similar vintage and specs. I also transferred the hard drive with the FreeDOS installation. With a PS/2 mouse connected, it booted fine -- the ICU driver configured the 3Com and the mouse worked. On this machine, I could enable/disable Legacy USB support. It booted fine either way. All was not well, however. Whenever I ran the ICU utility that reports on resource usage, it would lock the machine hard after loading the program interface. It did this with and without Legacy USB Support enabled, and with or without the PS/2 mouse plugged in.

My next move was to run this same second PC under Windows 98. The Realtek detected and installed OK, and Windows reported its resource usage without locking up. The mouse worked.

So I still don't see a firm conclusion to be drawn. Do some motherboard BIOS's not know what to make of the Realtek card? Are these Realtek cards poorly made? Or specially designed to be configured under Windows (though that wouldn't explain the early lock on PC #1)? Or does ICU not work well with this Realtek chip (though again, irrelevant on PC #1)?

On 5/13/2016 5:01 PM, John Hupp wrote:
I have a number of identical PNP ISA network cards based on the Realtek RTL8019AS chip that I would like to figure out how to run under FreeDOS.

I have not been able to determine the brand or manufacturer. There is a white sticker with "ESL-816VT", and screen-printed just above that "T292312T1AZZ0," but neither has led me to an identification. There is no FCC ID #.

So I'm trying to work with information and a DOS setup utility from Realtek. The chip is NE2000 compatible, so if I can get the hardware configured I should be in business.

The sticking point is that I can't get the PC to boot with the NIC installed and a PS/2 mouse connected. It stops at the point where the BIOS identifies/configures hardware. But if I hot unplug the mouse it will continue booting.

It will boot cleanly with a serial mouse, or with no mouse. But for various reasons I want to get it running with a PS/2 mouse.

It seems like a resource conflict, but I have not been able to find one. With the Intel ISA Configuration Utility (ICU) driver installed, the NIC is configured to use IRQ 3 and I/O 220. As I recall, that is also what the card defaults to without the ICU driver running.

The ICU suite has a utility that reports on resource usage, and IRQ 3 and I/O 220 are not reported to be in use by anything else. The PS/2 mouse should be using IRQ 12, reserved for this purpose.

I have also configured a card to use IRQ 10 and I/O 300, which are reported to be unused by anything else, and I get the same behavior when I connect a PS/2 mouse.

Interestingly, the RTL8019AS supports jumpered, jumperless and PNP modes, but in the implementation on this card there are no jumpers, and the Realtek utility is not able to switch the card out of its current PNP mode to jumperless mode.

Can anyone see what the problem is?

Mobile security can be enabling, not merely restricting. Employees who
bring their own devices (BYOD) to work are irked by the imposition of MDM
restrictions. Mobile Device Manager Plus allows you to control only the
apps on BYO-devices by containerizing them, leaving personal data untouched!
Freedos-user mailing list

Reply via email to