> Am 26.01.2017 um 18:19 schrieb Karen Lewellen <klewel...@shellworld.net>:
> As I am presently writing this e-mail using ssh2d386 from the ssh2dos 
> package ssh2021b,  perhaps I can help you troubleshoot.

Hi Karen!

I am using the exact same program and version.

> for the record, I am not using freedos, but  the ms dos 7.10 package 
> mentioned on this list.
> Still every day several times a day I connect  to two different servers 
> using  this package.

I guess your servers still run OpenSSH in versions earlier than 6.9.

> may I ask again what your issue is presently?

Actually I have given up on it. I spent another day trying to get it to work, 
but without success.

The problem is that I can’t connect to an Ubuntu 16.04 LTS server with OpenSSH 

SSH2D386 gives the message:

     Expected KEX_DH_GEX_GROUP
     DH key exchange failed

The server logs:
     Jan 27 00:02:22 ubuntu-VirtualBox sshd[2651]: error: kex protocol error: 
type 30 seq 1 [preauth]
     Jan 27 00:02:22 ubuntu-VirtualBox sshd[2651]: error: Received disconnect 
from port 645:3: Expected KEX_DH_GEX_GRO

As I wrote I already had problems connecting to a Debian 8 server with OpenSSH 
But there I could fix it with these lines in /etc/ssh/sshd_config on the server.

     Ciphers aes128-cbc
     KexAlgorithms diffie-hellman-group-exchange-sha1
     MACs hmac-sha1
     HostKeyAlgorithms ssh-css

But in OpenSSH 7.2 this didn’t work. 

What else did I try?

I tried to set MTU=576 in C:\FDOS\WATTCP.CFG.

I tried to recompile OpenSSH.
The first time with adding this line in in compat.c: 
     { "SSHDOS*",               SSH_OLD_DHGEX },
The second time with this one:
     { "SSHDOS*",               SSH_BUG_NOREKEY|SSH_BUG_FIRSTKEX },

Both were not able to let SSH2D386 connect. It worked great with other SSH 

The idea was that SSH2DOS uses code from PuTTY and there were already several 
exceptions in combat.c for old PuTTY versions. The reason seems to be that 
OpenSSH implemented RFC4419 and old PuTTY versions and SSH2DOS did not. See 
[1], [2]. 

I even looked at the SSH2DOS source code. But I have no experience with 
OpenWatcom. I installed it but gave up, when I saw I also had to compile the 
WATT32 TCP/IP stack.

SSH2DOS uses PuTTY code, which is also Free Software. So in theory it should be 
possible to replace the old PuTTY code with a more recent one.


[1] https://forums.red-gate.com/viewtopic.php?f=198&t=78958
[2] http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/rfc4419.html

Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
Freedos-user mailing list

Reply via email to