Pavel Zuna wrote:
Rob Crittenden wrote:
Pavel Zuna wrote:
I don't know how it happened, but the contents (except for the licence and module docstring) of ipaserver/__init__.py are gone when I do a new `git clone`.


I didn't investigate deeply into the issue, but mad this patch from a backup, so that David can continue his work.

Pavel

It was removed in patch "jderose 050 Run ipaserver under mod_wsgi". How is this preventing David from working?

rob
To be honest, I don't really know. There were some strange things going on with his installation I guess. Anyway, just ignore this patch.

Pavel

Before we replaced the __init__.py file I was getting errors like this:
(taken from irc log)

"ipa: ERROR: cannot connect to u'https://<ipaserver>': Internal Server Error

I ran ipa user-find and also ipa netgroup-show and both returned the same error
mnagy suggested check apache logs

The latest message is something about __init__.pyc contains no 'xmlrpc'

We replaced the .py file and the latest status was the above error no longer occurred but I still get ipa: ERROR: an internal error has occurred (http://pastebin.test.redhat.com/20693)


--

David O'Brien
Red Hat Asia Pacific Pty Ltd

He who asks is a fool for five minutes, but he who does not ask remains a fool forever."
 ~ Chinese proverb

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to