On Fri, 28 Jan 2011 19:11:39 -0500
Rob Crittenden <rcrit...@redhat.com> wrote:
> Simo Sorce wrote:
> > Use a common group named 'dirsrv' for all DS instances, as
> > requested in ticket #851
> > While there also remove the -u option, it is silly to allow to
> > change one in three (the other are group name and pki ds instance
> > user) accounts only. Plus it is apparently confusing to admins.
> > Simo.
> Just a couple of really minor nit-pickiness.
> If we are hardcoding the user why make it an argument to the various
> create_instance commands? You already import the group from
> dsinstance, why not the user too?
I didn't want to change too much code :-)
I'll change that, hopefully w/o introducing regressions.
> And this code:
> if not group_exists is None and not group_exists:
> might be more readable as:
> if group_exists == False:
I copied from dsinstance.uninstall() I will change it.
Simo Sorce * Red Hat, Inc * New York
Freeipa-devel mailing list