On (24/02/16 11:06), Petr Vobornik wrote:
>On 02/24/2016 09:50 AM, Lukas Slebodnik wrote:
>>On (23/02/16 14:23), Rob Crittenden wrote:
>>>Lukas Slebodnik wrote:
>>>>On (23/02/16 17:09), Martin Basti wrote:
>>>>>We cannot guarantee that versions older than 1.4 will work with freeipa 
>>>>>Patch attached.
>>>>>From a59e72a0b87231c0f2e0d737057550dd532feed7 Mon Sep 17 00:00:00 2001
>>>>>From: Martin Basti <mba...@redhat.com>
>>>>>Date: Tue, 23 Feb 2016 16:58:07 +0100
>>>>>Subject: [PATCH] Set BuildRequires to pylint >= 1.4
>>>>>We can guarantee that only pylint 1.4 and newer will work
>>>>>freeipa.spec.in | 2 +-
>>>>>1 file changed, 1 insertion(+), 1 deletion(-)
>>>>>diff --git a/freeipa.spec.in b/freeipa.spec.in
>>>>> 100644
>>>>>--- a/freeipa.spec.in
>>>>>+++ b/freeipa.spec.in
>>>>>@@ -76,7 +76,7 @@ BuildRequires:  python-netaddr
>>>>>BuildRequires:  python-gssapi >= 1.1.2
>>>>>BuildRequires:  python-rhsm
>>>>>BuildRequires:  pyOpenSSL
>>>>>-BuildRequires:  pylint >= 1.0
>>>>>+BuildRequires:  pylint >= 1.4
>>>>I can build rpms even withour pylint and pylint is not executed
>>>>anywhere in spec file. (in other words, my patch was rejected)
>>>>Why does it need to be in BuildRequires?
>>>pylint is part of the in-tree build process (make rpms). It is not
>>>executed when building upstream packages.
>>It's not buildrequires becuase I can rebuild src.rpm
>>without it. It should not be there or it should be optional
>>to do not break developer workflow.
>>e.g. "%bcond_with extra_dependencies_for_pylint"
>>The upstream spec files is close to the fedora spec file
>>and pylint is istalled there even though it's not used.
>>Another use case is coverity scan.
>Basically I agree with Lukas but this patch is the way how we do build
>upstream right now.
>The proposed change would required more refactoring of build process and is
>out of scope of this ticket. Feel free to open a ticket for it. It should not
>block this patch.
I have a different opinion here.

The ticket #5615 says: "Prepare IPA for pylint 1.5.2"
It does not say anything about minimal requirement on pylint 1.4
even though all current version of fedora has pylint 1.4.

Older version of pylint (1.3.1) is available only in fedora 20.
Which is out of support for more than a year.
Patch is neither required for fedora nor for ticket #5615

However there is only pylint-1.3.1 in epel7
And it would cause issues there.

Summary: This patch does not solve anything.


Manage your subscription for the Freeipa-devel mailing list:
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to