On 12/14/2016 02:53 AM, Ben Lipton wrote:
Hi all,

I'm pretty sure this is unrelated to the CI issues discussed in other threads recently, but they reminded me that I've been having this odd issue.

https://travis-ci.org/freeipa/freeipa/jobs/183756995 is the most recent run on my pull request, https://github.com/freeipa/freeipa/pull/10. For a while now, every time the CI runs on my PR, it fails due to several PEP8 errors that are not detected when I run `git diff master -U0 | pep8 --diff` on my local copy. In fact, the errors are all in files not touched by my PR, which doesn't make much sense to me based on the behavior of `git diff`.

I noticed that the top of the travis build says:

 - Commit 1f50550
 - #10: Client-side CSR autogeneration
 - Branch master

I'm not sure what the "commit" link actually means, but that commit seems to have nothing to do with my PR nor the current master. Could Travis be diffing against the wrong code? Or if not, do you have any idea what might be causing these failures?

Thanks,
Ben

Hi Ben,

I was going through the Travis CI log of and noticed what might have caused the issue:

$ cd freeipa/freeipa
$ git fetch origin +refs/pull/109/merge:

It seems that for your pull request #10 (and for some reason for your pull request only), Travis fetched a different (old) pull request which it then tried to merge with current master, hence the errors. I don't think it was testing your code at all.

I do not have an explanation for this other than it might be a Travis bug, CCing Martin for a better answer.

Standa
-- 
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to