I'm having strange issues with removing one of my freeIPA masters, I
managed to mess up the deletion process and my system seems to be stuck in
a state of limbo, my current setup is 3 servers ( 1 has been
decommissioned) that all share the CA/Domain responsibilities. When i run
the command .

*ipa-replica-manage list*

it produces 3 servers as active masters, when this is not true as i have
uninstalled ipa-server on one. Trying to delete it through that command has
given me no luck, even using *--force* and *--cleanup* does not work. the
same error output appears:

*oxygen.eggvfx.ie <http://oxygen.eggvfx.ie>: server not found*

I'm not very good with ldap tools but after running

*ldapsearch -x *

there is a reference to the oxygen server still sitting in there, it seems
that the dirty entry is still hanging around my system, i'm wondering if
there is any way to resolve this?

ldapsearch output:
*defaultServerList: oxygen.eggvfx.ie <http://oxygen.eggvfx.ie>
nitrogen.eggvfx.ie <http://nitrogen.eggvfx.ie> lithium.eggvfx.ie

Looking at the topology graph in the web ui i can see that there are still
ties between one of my servers and oxygen. It will also not allow me to
delete the server ties ( error: *Server is unwilling to perform: Removal of
Segment disconnects topology.Deletion not allowed.)* nor will the ui allow
me to delete the IPA server (*oxygen.eggvfx.ie <http://oxygen.eggvfx.ie>:
server not found*)

Any help is greatly appreciated,

Many Thanks,
Jamal Mahmoud
FreeIPA-users mailing list -- freeipa-users@lists.fedorahosted.org
To unsubscribe send an email to freeipa-users-le...@lists.fedorahosted.org

Reply via email to