On Fri, Feb 10, 2012 at 10:18 PM, John Dennis <jden...@redhat.com> wrote:

> On 02/10/2012 03:49 PM, Marco Pizzoli wrote:
>
>> --> Finished Dependency Resolution
>> *Error: Protected multilib versions: libldb-1.1.0-1.fc16.i686 !=
>> libldb-1.1.4-1.fc16.1.x86_64*
>>
>
> This error is because you've got both a 32-bit and 64-bit version of
> libldb installed, note how the 32-bit version is 1.1.0 and the 64-bit
> version is 1.1.4, they're not the same.
>

Actually I think the situation is a little bit different.

To explain myself better I start by posting this output:

[root@freeipa02 ~]# rpm -qa|grep libldb
libldb-1.1.0-1.fc16.x86_64

Look for a second at the output i posted before. As you can see

[cut]
--> Running transaction check
---> Package libldb.i686 0:1.1.0-1.fc16 will be installed
[cut]

The package libldb-32bit is being submitted to yum as a candidate from a
dependence on a package situated in your ipa-devel repository.

I'm not a yum expert, can you confirm what I notice?



> However the ipa-devel repo does have both the 32-bit and 64-bit version of
> 1.1.4 available in the x86-64 repo
>
> ipa-devel/fedora/16/x86_64/os/**libldb-1.1.4-1.fc16.1.i686.rpm
> ipa-devel/fedora/16/x86_64/os/**libldb-1.1.4-1.fc16.1.x86_64.**rpm
>
> So the repo looks good, not sure what yum is complaining about, it should
> see both 32-bit and 64-bit is available for version 1.1.4 and install both,
> unless of course you've got a dependency on the 1.1.0 32-bit version, but
> yum should tell you that.
>
> That's about as much help as I can give you at the moment.
>
>
> --
> John Dennis <jden...@redhat.com>
>
> Looking to carve out IT costs?
> www.redhat.com/carveoutcosts/
>



-- 
_________________________________________
Non รจ forte chi non cade, ma chi cadendo ha la forza di rialzarsi.
                    Jim Morrison
_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to