Good thought.  I just tried it and it still fails:

[karmstrong@linuxtest<mailto:karmstrong@linuxtest> ~]$ ipa user-mod karmstrong 
--sshpubkey "$(cat .ssh/id_rsa.pub)"
ipa: ERROR: invalid 'sshpubkey': invalid SSH public key


On Mon, 2013-07-15 at 17:09 +0200, Jan Pazdziora wrote:


On Mon, Jul 15, 2013 at 02:40:19PM +0000, Armstrong, Kenneth Lawrence wrote:
> I'm trying to add an SSH public key to a user, and I keep getting IPA Error 
> 3009 or IPA Error 3008 when I try to update the page.  I have copied over the 
> exact contents of the .ssh/id_rsa.pub file.  Even if I take the username 
> portion out at the end of the file, I still get the same error messages.
>
> When I try to add it from the command line, I get:
>
> ipa: ERROR: invalid 'sshpubkey': invalid SSH public key
>
> And yes, I verified that ssh-rsa is at the beginning of the key output.
>
> This is on a RHEL 6 server.
>
> Any thoughts?

Does it fail even if you do not copy-n-paste the key but let shell
expand it as

        ipa user-mod demo --sshpubkey "$( cat /tmp/demo.pub )"

?



--

Kenny Armstrong
System Administrator
IS Operations

[http://www.liberty.edu/media/1616/40themail/wordmark-for-email.jpg]<http://www.liberty.edu/media/1616/40themail/wordmark-for-email.jpg>

Training Champions for Christ since 1971

<<attachment: wordmark-for-email.jpg>>

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to