I do not believe that it is damaged.  I have tried this out three times now 
(deleting the key files between each attempt).

-Kenny

On Mon, 2013-07-15 at 17:30 +0200, Tomas Babej wrote:
On Monday 15 of July 2013 15:13:49 Armstrong, Kenneth Lawrence wrote:

> Good thought. I just tried it and it still fails:

>

> [karmstrong@linuxtest<mailto:karmstrong@linuxtest> ~]$ ipa user-mod 
> karmstrong --sshpubkey "$(cat .ssh/id_rsa.pub)"

> ipa: ERROR: invalid 'sshpubkey': invalid SSH public key

>



Are you sure the ssh public key file is not damaged? The following sequence of 
commands works for me (verified now):



[root@vm-154 tbabej]# ssh-keygen

Generating public/private rsa key pair.

Enter file in which to save the key (/root/.ssh/id_rsa): /home/tbabej/test_rsa

[..]



[root@vm-154 tbabej]# ipa user-mod admin --sshpubkey "$(cat test_rsa.pub)"

---------------------

Modified user "admin"

---------------------

User login: admin

Last name: Administrator

Home directory: /home/admin

Login shell: /bin/bash

[..]



Tomas


_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to