On Sun, 2013-12-29 at 11:40 +0100, Thomas Sailer wrote:
> I've updated the machine running freeipa from f18 to f20.
> 
> Now I still have the old pki-base package 
> (pki-base-10.0.6-1.fc18.noarch). Trying to upgrade it results in the 
> following message:
> 
> error: lua script failed: [string 
> "%pretrans(pki-base-10.1.0-1.fc20.noarch)"]:22: Unable to upgrade to 
> Fedora 20.  There are Dogtag 9 instances
> that will no longer work since they require Tomcat 6, and
> Tomcat 6 is no longer available in Fedora 20.
> 
> Please follow these instructions to migrate the instances to
> Dogtag 10:
> 
> http://pki.fedoraproject.org/wiki/Migrating_Dogtag_9_Instances_to_Dogtag_10
> Error in PRETRANS scriptlet in rpm package pki-base-10.1.0-1.fc20.noarch
> 
> The above mentioned wiki page suggests that the easiest way to upgrade 
> dogtag is by creating a replica.
> 
> However, ipa-replica-prepare fails with:
> [Errno 2] No such file or directory: '/etc/pki/pki-tomcat/password.conf'
> 
> There isn't even a directory named /etc/pki/pki-tomcat
> 
> This server has separate dirserv instances for PKI and the rest.
> 
> Does anyone have an idea how to do the dogtag upgrade?

Unfortunately you should have created the replica *before* the upgrade.
Have you tried downgrading all dogtag and tomcat packages to the fc18
ones ?

Simo.

-- 
Simo Sorce * Red Hat, Inc * New York

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to