>
>
>
>  has anyone worked it out. Secondly cifs-utils has dependency on samba3
> packages and ipa-ad-trust needs samba4 but samba3 and samba4 don't like
> each other , so this is the story of my experience with ipa. Any
> suggestions ?
>
>
> Why do you need cifs-utils on the same server?
> cifs-utils to make a system a client to MSFT file server, AFAIU you cant
> make IPA server to be a cifs client.
>
>
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Identity_Management_Guide/trust-diff-dns-domains.html

Step 3 mentions that cifs-utils is required, but:

yum install cifs-utils
Loaded plugins: product-id, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
rhel-6-server-cf-tools-1-rpms                                 | 2.8 kB
00:00
rhel-6-server-rhev-agent-rpms                                 | 3.1 kB
00:00
rhel-6-server-rpms                                            | 3.7 kB
00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package cifs-utils.x86_64 0:4.8.1-19.el6 will be installed
--> Processing Dependency: libwbclient.so.0()(64bit) for package:
cifs-utils-4.8.1-19.el6.x86_64
--> Running transaction check
---> Package samba-winbind-clients.x86_64 0:3.6.9-167.el6_5 will be
installed
--> Processing Dependency: samba-winbind = 3.6.9-167.el6_5 for package:
samba-winbind-clients-3.6.9-167.el6_5.x86_64
--> Running transaction check
---> Package samba-winbind.x86_64 0:3.6.9-167.el6_5 will be installed
--> Processing Dependency: samba-common = 3.6.9-167.el6_5 for package:
samba-winbind-3.6.9-167.el6_5.x86_64
--> Running transaction check
---> Package samba-common.x86_64 0:3.6.9-167.el6_5 will be installed
--> Processing Conflict: samba4-common-4.0.0-60.el6_5.rc4.x86_64 conflicts
samba-common < 3.9.9
--> Processing Conflict: samba4-winbind-4.0.0-60.el6_5.rc4.x86_64 conflicts
samba-winbind < 3.9.9
--> Processing Conflict: samba4-winbind-clients-4.0.0-60.el6_5.rc4.x86_64
conflicts samba-winbind-clients < 3.9.9
--> Finished Dependency Resolution
Error: samba4-common conflicts with samba-common-3.6.9-167.el6_5.x86_64
Error: samba4-winbind-clients conflicts with
samba-winbind-clients-3.6.9-167.el6_5.x86_64
Error: samba4-winbind conflicts with samba-winbind-3.6.9-167.el6_5.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Is this no longer a requirement? Can this documentation be updated?

Steve
_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to