Actually, I did find a fix and forgot to post.

I was able to mirror the COPR repo, and after reviewing it, found that simply removing the pki-base...fc21 directory, and regenning the repo data with createrepo, fixed the problem. It drops the version of PKI back to the 10.1 branch and that resolved the dependencies.


Hope this helps,
Janelle

On 10/13/14 9:48 PM, Fraser Tweedale wrote:
On Mon, Oct 13, 2014 at 09:52:40AM -0700, Janelle wrote:
After further investigation - it looks like the PKI base was altered/updated
because even on a running server a yum update produces same error:

# yum check-update
Loaded plugins: fastestmirror, product-id, subscription-manager, versionlock
Loading mirror speeds from cached hostfile
  * base: linux.mirrors.es.net
  * extras: mirrors.usinternet.com
  * updates: centos.host-engine.com

pki-base.noarch 10.2.0-3.el7.centos                              freeipa
pki-ca.noarch 10.2.0-3.el7.centos                              freeipa
pki-server.noarch 10.2.0-3.el7.centos                              freeipa
pki-tools.x86_64 10.2.0-3.el7.centos                              freeipa
slapi-nis.x86_64 0.54-1.el7.centos                                freeipa

and: if you select yes:

---> Package pki-base.noarch 0:10.2.0-3.el7.centos will be an update
--> Processing Dependency: jackson-jaxrs-json-provider for package:
pki-base-10.2.0-3.el7.centos.noarch
--> Finished Dependency Resolution
Error: Package: pki-base-10.2.0-3.el7.centos.noarch (freeipa)
            Requires: jackson-jaxrs-json-provider
  You could try using --skip-broken to work around the problem

Hi Janelle,

Looks like the COPR moved from Dogtag 10.1 to 10.2 on 8 Oct, and
10.2 declares a dependency on Jackson which is not in EPEL.  The
dependency causing the probelm (jackson-jaxrs-json-provider) was
introduced at commit 32d71bb.  I'm not sure on the right approach to
fixing this but I've copied pki-devel who will be able to help.

Fraser


On 10/13/14 9:18 AM, Janelle wrote:
Happy Monday everyone...

Wondering if anyone else is seeing this error since this weekend? Trying
to add in a new IPA replica, which of course requires the software
installed -- this is in CentOS 7 using COPR repo and :

--> Finished Dependency Resolution
Error: Package: pki-base-10.2.0-3.el7.centos.noarch (ipa)
           Requires: jackson-jaxrs-json-provider

and yet,  I have never had that issue until this weekend. :-(

Any help?
Janelle
--
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go To http://freeipa.org for more info on the project

--
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go To http://freeipa.org for more info on the project

Reply via email to