I checked again my web UI and it starts working - i really did not
change anything. Right now i'm getting list of records immediately
without "Waiting" inscription and no errors in log file. What could be
a reason of such behave, how to fix it if it appear again? I think
problem was that long execute time like Rob wrote, but what might have
caused it?
On Thu, 2015-11-19 at 07:52 +0100, Unknown wrote:
> On Wed, 2015-11-18 at 13:49 -0500, Rob Crittenden wrote:
> > Unknown wrote:
> > > I'm new here so first of all want to say hello to everyone.
> > > 
> > > I'm implementing FreeIPA in our environment. Everything was fine
> > > till i
> > > figure out listing of one domain stops working. When im trying to
> > > list
> > > zone via web panel i'm getting "Internal Server Error". It is
> > > happening
> > > only for default one zone/domain which is used by kerberos too.
> > > Here are
> > > http error logs:
> > > 
> > > [Wed Nov 18 06:13:45.226059 2015] [:error] [pid 11045] (70007)The
> > > timeout specified has expired: [client 172.16.0.117:48072]
> > > mod_wsgi
> > > (pid=11045): Unable to get bucket brigade for request., referer:
> > > https://freeipa01.domain.local/ipa/ui/
> > > [Wed Nov 18 06:13:45.226607 2015] [:error] [pid 3929] ipa: ERROR:
> > > non-public: IOError: request data read error
> > > [Wed Nov 18 06:13:45.226645 2015] [:error] [pid 3929] Traceback
> > > (most
> > > recent call last):
> > > [Wed Nov 18 06:13:45.226672 2015] [:error] [pid 3929]   File
> > > "/usr/lib/python2.7/site-packages/ipaserver/rpcserver.py", line
> > > 339, in
> > > wsgi_execute
> > > [Wed Nov 18 06:13:45.226680 2015] [:error] [pid 3929]     data =
> > > read_input(environ)
> > > [Wed Nov 18 06:13:45.226685 2015] [:error] [pid 3929]   File
> > > "/usr/lib/python2.7/site-packages/ipaserver/rpcserver.py", line
> > > 187, in
> > > read_input
> > > [Wed Nov 18 06:13:45.226693 2015] [:error] [pid 3929]     return
> > > environ['wsgi.input'].read(length)
> > > [Wed Nov 18 06:13:45.226698 2015] [:error] [pid 3929] IOError:
> > > request
> > > data read error
> > > [Wed Nov 18 06:13:45.226964 2015] [:error] [pid 3929] ipa: INFO:
> > > [jsonserver_session] admin@DOMAIN.LOCAL 
> > > L>:
> > > None: IOError
> > > [Wed Nov 18 06:13:45.227879 2015] [:error] [pid 3929] [remote
> > > 172.16.0.117:164] mod_wsgi (pid=3929): Exception occurred
> > > processing
> > > WSGI script '/usr/share/ipa/wsgi.py'.
> > > [Wed Nov 18 06:13:45.227932 2015] [:error] [pid 3929] [remote
> > > 172.16.0.117:164] IOError: failed to write data
> > 
> > More context would be helpful. I'm assuming that this took a VERY
> > long
> > time to execute? It looks like the wsgi request timed out.
> > 
> > Can you duplicate this on the CLI using the ipa tool?
> > 
> CLI is working without any problems i can list, add, delete records,
> problem only appear in web interface when i want to list my default
>  zone (others are working for now).
> 
> According to that long time execute. Internal server error appears
> for around 10 sec. I'm not familiar with wsgi but i tried to add
> " inactivity-timeout=60" option to "WSGIDaemonProcess" in ipa.conf
> like bellow:
> 
> WSGIDaemonProcess ipa processes=2 threads=1 maximum-requests=500
> inactivity-timeout=60
> 
> but it did not help.
> 
> 
> > > I realize that it stops working after i try to add Ubuntu
> > > instance but
> > > Ubuntu client is not work properly. What is strange when im using
> > > command client i don't have problem to list it.
> > 
> > I'm not sure I follow. Was it a coincidence after registering an
> > Ubuntu
> > client or do you think it's the cause?
> I noticed it after i tried to add ubuntu instance to my freeipa maybe
> this is not connected with it.
> 
> > rob
> > 
-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to