On to, 27 loka 2016, David Kupka wrote:
On 26/10/16 20:00, lejeczek wrote:
hi all

quick question - does IPA rpms depend on samaba's?
I'm hoping I can remove samba-common but dnf fies a 46 packages long
list of dependencies - is it somehow broken?
If is not and that is 100% correct long chain of deps - then can samba
be safely downgraded to 3.6.x ? given that IPA does not integrate samba
in my configuration.

many thanks
L.


Hello!

Only freeipa-server-trust-ad package depends on samba. If you haven't configured AD trust you can safely remove samba (and also freeipa-server-trust-ad package if you've installed it). samba-common contains files for samba client and server so removing it may remove applications that can behave as samba client.
That's not fully correct. FreeIPA 4.2+ has 389-ds plugins which link to
Samba components and are part of freeipa-server package because we
configure them by default to make trust agent configuration easy:

# rpm -q --requires freeipa-server|grep ^lib|xargs -n1 rpm -q 
--whatprovides|sort -u
glibc-2.23.1-10.fc24.x86_64
krb5-libs-1.14.4-4.fc24.x86_64
libcom_err-1.42.13-4.fc24.x86_64
libgcc-6.2.1-2.fc24.x86_64
libsss_nss_idmap-1.14.2-1.fc24.x86_64
libtalloc-2.1.6-1.fc24.x86_64
libtevent-0.9.28-1.fc24.x86_64
libunistring-0.9.4-3.fc24.x86_64
libuuid-2.28.2-1.fc24.x86_64
libverto-0.2.6-6.fc24.x86_64
nspr-4.13.1-1.fc24.x86_64
nss-3.27.0-1.1.fc24.x86_64
nss-util-3.27.0-1.0.fc24.x86_64
openldap-2.4.44-1.fc24.x86_64
openssl-libs-1.0.2j-1.fc24.x86_64
samba-client-libs-4.4.6-1.fc24.x86_64

You cannot remove samba-client-libs due to this.

We also do not support downgrading Samba.

--
/ Alexander Bokovoy

--
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to