On Fri, Jan 04, 2013 at 10:37:11AM +0200, Timo Aaltonen wrote:
>   I'm requesting a MRE for SSSD. Upstream* generally supports
> several branches at any time; one or two LTM (long term maintenance)
> branches and the latest non-LTM stable branch. The current supported
> branches are:
> 
> 1.5.x LTM
  ^- Ubuntu 11.10
> 1.8.x LTM
  ^- Ubuntu 12.04 LTS
> 1.9.x
  ^- Ubuntu 12.10
> (1.10 will be the next LTM)
> 
> There is no written policy about allowing only bugfixes on the
> stable branches. Actually, 1.5.x did receive features upstream
> deemed appropriate for it, but the other branches haven't. There is
> a test-suite that is run during package build, but due to the nature
> of the package it's impractical to cover every use case. The stable
> releases are being tested by upstream and the community though (and
> Fedora users which get the updates quickly, RHEL later), so giving a
> few weeks after a release should reveal the regressions a release
> might have.

I probably don't have much in the way of objection.  However, the only
SRU for sssd that's ever made it as far as -proposed was for bug 585885,
which failed the SRU process due to a lack of testers.  Do you have
plans for marshalling efforts to verify SRUs under an MRE such as this?

-- 
Colin Watson                                       [cjwat...@ubuntu.com]

_______________________________________________
Mailing list: https://launchpad.net/~freeipa
Post to     : freeipa@lists.launchpad.net
Unsubscribe : https://launchpad.net/~freeipa
More help   : https://help.launchpad.net/ListHelp

Reply via email to