Jackson Jerry-NPC637 wrote:

> 1.  I’ve installed version 1.1.6, but have some dictionary files that
> are/were setup for
>     Freeradius 1.1.3.  I’ve seen from the README/faq that the dictionary
> files have changed post 1.1.3

  The dictionary files that are shipped with the server have changed.
You MUST use the new dictionaries with 1.1.6, for a number of reasons.

>     & am wondering what I need to do/change to incooperate my 1.1.3
> dictionary files to work with
>     Freeradius 1.1.6?  It looks like most of the 1.1.3 dict. files are
> duplicated in 1.1.6, but notice I have
>     a couple (company specific) dictionary files that I need to use with
> freeradius 1.1.6? 

  That's what /etc/raddb/dictionary is for.  You should $INCLUDE the
dictionaries from 1.1.6, and then $INCLUDE your local dictionaries.  Do
NOT edit the dictionaries in /usr/share.

> 2. Probably not a big deal (just curious), but was wondering what
> exactly changed with the dictionary 
>     files between freeradius 1.1.3 & 1.1.6.  I see an error like “values
> can only be Interger types”, but am not
>     sure what this means.  Hopefully this is just a quick/short answer.

  The old dictionaries contained inconsistent and contradictory
information.  The new dictionaries don't, and the code no longer allows
those kind of problems.

  Alan DeKok.
--
  http://deployingradius.com       - The web site of the book
  http://deployingradius.com/blog/ - The blog
- 
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html

Reply via email to