On Sat, Jun 06, 2026 at 07:56:12PM +0800, Qian Yun wrote:
> First, there is a variable misname.

There is mismatch.  'in_core?' is a better name, so the itent was
to use it instead of 'inCore'.
 
> Second, to save history in "axh" format, a directory is needed.
> So set the second argument of kaf_open to true.

Yes, to write we need writable library.

> diff --git a/src/interp/i-syscmd.boot b/src/interp/i-syscmd.boot
> index ae6a2564..9dbe3a33 100644
> --- a/src/interp/i-syscmd.boot
> +++ b/src/interp/i-syscmd.boot
> @@ -1481,7 +1481,7 @@ optargs, 1)
>    'done
> 
> -say_file_or_core_msg(in_core?) ==
> +say_file_or_core_msg(inCore) ==
>      inCore => say_msg("S2IH0032", CONCAT(
>          '"When the history facility is active, history information will
> be",
>          '" maintained in memory (and not in an external file)."), nil)
> @@ -1513,7 +1513,7 @@
>      say_file_or_core_msg(true)
>    $HiFiAccess:= 'NIL
>    histFileErase histFileName()
> -  str := kaf_open(histFileName(), false)
> +  str := kaf_open(histFileName(), true)
>    for [n,:rec] in reverse $internalHistoryTable repeat
>        SPADRWRITE(str, object2String2(n), rec)
>    kaf_close(str)
> 
> -- 
> You received this message because you are subscribed to the Google Groups 
> "FriCAS - computer algebra system" group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to [email protected].
> To view this discussion visit 
> https://groups.google.com/d/msgid/fricas-devel/013fbe6e-6cb2-47a8-82c3-3bab3f721002%40gmail.com.

-- 
                              Waldek Hebisch

-- 
You received this message because you are subscribed to the Google Groups 
"FriCAS - computer algebra system" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion visit 
https://groups.google.com/d/msgid/fricas-devel/aiQW9GdmpWnNt-O8%40fricas.org.

Reply via email to