I'm a long-time user of FVWM. I'm currently using it on Debian,
with the following package:

ii  fvwm      1:2.6.5.ds-3 amd64     F(?) Virtual Window Manager

Recently, I have built a XEN machine to consoldiate old servers into
one small box, on which I have no display.  Hence I have setup a
VNC server on that box and I run fvwm on that display as well.

Now, for some reason that I cannot figure out, Key bindings on the
VNC server are not installed by FVWM.  I checked that by using:

        PrintInfo bindings

which only list the Mouse bindings, but no Key bindings at all.

On my Linux workstation, where I use FVWM as well (same version, same
package, only this time the display is a real X server), both Mouse
and Key bindings are output correctly (and work).

The ~/.fvwm2rc files are identical on the VNC server and on my

I ran "xev" on my workstation, and within the vncviewer window and
checked that key events are correctly received.  Just for sanity, but
I knew they were because I can interact on the vncviewer with all my
Mouse bindings, some involving keyboard combinations like "Alt - click3"
to iconify a window, which work perfectly.

However, pure key bindings events are ignored, and since FVWM does not
list them in the "PrintInfo bindings" but does not otherwise complain
about anything in the stdout/stderr log file, I'm looking for some
way to diagnose the problem!

The VNC server I use is:

        ii  vnc4server  4.1.1+X4.3.0 amd64  Virtual network computing server

The VNC viewer I use is xtightvncviewer on Linux, and Real VNC on
Windows.  But the problem is not in the client (viewer) part since
FVWM does not install bindings for some reason.

Please, can you give me a hint at what to look for, which debugging I
could activate, which checks I could do to understand what prevents
FVWM from installing the Key bindings on the VNC X server?


Reply via email to