Hello Marcel,

This should now be working.  The problem you encountered was due to the timeout 
setting in nginx being too short - this is fixed.  In addition, I've added the 
ability to enter a URL into the upload form in the tool shed.  I've also fixed 
several bugs, including renaming the repository and one related to deleting 
repository files.  There are several other new features available as well - 
they'll soon be documented in the tool shed wiki.  Let me know if you bump into 
any other problems.

Thanks!

On Nov 12, 2011, at 5:22 PM, Marcel Schumann wrote:

> Hi Greg,
> 
> ok, thanks.
> Just for your information: uploading a relatively big package (approx. 15mb) 
> worked previously for me without any problems.
> 
> However, if you will implement some new package-update mechanism anyway, a 
> very nice feature would be the support of downloads from remote servers 
> (instead of upload from the local computer); just as the 'Upload File' tool 
> allows to do in Galaxy. :-)
> 
> 
> Best regards,
> Marcel
> 
> 
> On 11/12/11 10:18 PM, Greg Von Kuster wrote:
>> Hi Marcel,
>> 
>> Thanks very much for alerting me to the problem with the tool shed.  I've 
>> got it functional again for the time being.  I believe there's a problem 
>> with renaming a repository (which I'll fix asap) that caused the server 
>> error you saw.  I'll also take a look at uploading your new version of your 
>> CADDSuite - I'm assuming we'll need to implement an ftp upload process 
>> because the browser may be timing out with the larger upload.  I'll let you 
>> know what I find (I'll probably get back to you on Monday).
>> 
>> Thanks again,
>> 
>> Greg Von Kuster
>> 
>> On Nov 12, 2011, at 11:58 AM, Marcel Schumann wrote:
>> 
>>> Hi Dave, hi Greg,
>>> 
>>> During the last few days, I tried several times to upload the current 
>>> version of CADDSuite (1.0.1) to the galaxy tool shed; however, I always 
>>> just got time-out errors.
>>> 
>>> Now I have just had a look at the tool shed again, but most tool category 
>>> can't even be viewed ('Server error'). So, is there any work with the tool 
>>> shed server currently going on? Any reason why it can't work in the moment? 
>>> ;-)
>>> 
>>> By the way, if you (for debugging purposes) want to try to upload my 
>>> packages yourself:
>>> The packages are available from the project's homepage 
>>> http://caddsuite.github.com
>>> 
>>> https://github.com/downloads/CADDSuite/main/CADDSuite_1.0.1_Linux_x86-64.tar.gz
>>> https://github.com/downloads/CADDSuite/main/CADDSuite_1.0.1_MacOS_10.6.tar.gz
>>> 
>>> 
>>> Cheers,
>>> Marcel
>>> 
>> 
>> Greg Von Kuster
>> Galaxy Development Team
>> g...@bx.psu.edu
>> 
>> 
>> 
> 
> 
> -- 
> Marcel Schumann
> 
> University of Tuebingen
> Wilhelm Schickard Institute for Computer Science
> Division for Applied Bioinformatics
> Room C313, Sand 14, D-72076 Tuebingen
> 
> phone:  +49 (0)7071-29 70437
> fax:  +49 (0)7071-29 5152
> email:  schum...@informatik.uni-tuebingen.de

Greg Von Kuster
Galaxy Development Team
g...@bx.psu.edu




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to