Hi,

I tried to run a workflow with the API, but get an Error 500 when I try to run the WF...The paster.log shows the following error...

$ workflow_execute.py 92cc01ed93dc0f0fc91e3ded35497c0a http://srp106:8080/api/workflows ebfb8f50c6abde6d 'TEST the API' '1=ldda=7c5ebce002fc9d5c'


Paster.log
galaxy.web.framework ERROR 2012-02-21 14:36:33,067 Uncaught exception in exposed API method:
Traceback (most recent call last):
  File "/home/tdeboer/code/galaxy-central/lib/galaxy/web/framework/__init__.py", line 145, in decorator
    return simplejson.dumps( func( self, trans, *args, **kwargs ), indent=4, sort_keys=True )
  File "/home/tdeboer/code/galaxy-central/lib/galaxy/web/api/workflows.py", line 123, in create
    hda = ldda.to_history_dataset_association(history, add_to_history=add_to_history)
AttributeError: 'NoneType' object has no attribute 'to_history_dataset_association'
172.16.108.6 - - [21/Feb/2012:14:36:32 -0700] "POST /api/workflows?key=92cc01ed93dc0f0fc91e3ded35497c0a HTTP/1.1" 500 - "-" "Python-urllib/2.6"


Any ideas?

Also...I had a hard time finding out what I should use for the dataset source parameter "src" in "step=src="" and just tried ldda, but would hope there is a little info on what this hda and ldda is?

Thanks,

Thon
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to