Hi all,

We get the behavior mentioned some times too, its not reproducible
just like you mentioned.  Some times it happens with small files, some
times with large files and again as you said it doesn't happen all the
time.

Now I haven't seen this yet on our Galaxy dev server which is the
latest galaxy-dist, only see this on our Galaxy production which is an
older version of galaxy-dist from last winter.

regards,
Leandro

On Wed, Feb 22, 2012 at 3:59 PM, Hans-Rudolf Hotz <h...@fmi.ch> wrote:
> Hi
>
> I guess we see similar things: a new history item is created, it turns
> purple, stays like this apparently forever while no job id is created (ie I
> don't see the job in any of the report tools).
>
> To be honest we ignore them, because:
>
> a) it only (as far as I can tell) happens with big data files (we try to
> avoid this anyway by using 'Data libraries') while there is heavy load on
> the storage system
>
> b) ...eventually, unless the user has deleted the history item, it does turn
> green and the job is listed as 'ok'.
>
>
> Do you experience this problem with all files, even small ones?
>
>
> Regards, Hans
>
>
>
> On 02/22/2012 10:14 AM, Jorrit Boekel wrote:
>>
>> Dear list,
>>
>> I have stumbled on some strange behaviour when uploading files to galaxy
>> via the upload.py tool. At times, the upload seems to be stalled in
>> history and is never actually performed, followed by a seemingly
>> infinite history update (see log below). My system is Ubuntu 11.10 and
>> runs Python 2.7.2. I find the behaviour in both my own modified galaxy
>> install (based on galaxy-dist), and in a fresh clone from galaxy-central.
>>
>> I have tried to upload different files, and all seem to sometimes
>> trigger the behaviour, but not all the time. A restart of galaxy
>> sometimes sorts things out. Common for the debug messages is that it
>> seems there is never a job id generated as in
>> "galaxy.tools.actions.upload_common INFO 2012-02-22 10:06:36,186 tool
>> upload1 created job id 2".
>>
>> Has anyone seen similar things or can it be a problem with my system?
>>
>> cheers,
>> jorrit
>>
>>
>>
>>
>>
>>
>> --------------Debug messa:
>>
>> galaxy.web.framework DEBUG 2012-02-22 09:47:43,730 Error: this request
>> returned None from get_history(): http://localhost:8080/
>> 127.0.0.1 - - [22/Feb/2012:09:47:43 +0200] "GET / HTTP/1.1" 200 - "-"
>> "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101
>> Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:47:44 +0200] "GET /root/tool_menu
>> HTTP/1.1" 200 - "http://localhost:8080/"; "Mozilla/5.0 (X11; Ubuntu;
>> Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:47:44 +0200] "GET /history HTTP/1.1" 200 -
>> "http://localhost:8080/"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:47:44 +0200] "POST /root/user_get_usage
>> HTTP/1.1" 200 - "http://localhost:8080/history"; "Mozilla/5.0 (X11;
>> Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:47:50 +0200] "GET
>> /tool_runner?tool_id=upload1 HTTP/1.1" 200 -
>> "http://localhost:8080/root/tool_menu"; "Mozilla/5.0 (X11; Ubuntu; Linux
>> x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:11 +0200] "POST
>> /tool_runner/upload_async_create HTTP/1.1" 200 -
>> "http://localhost:8080/"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:11 +0200] "GET
>> /tool_runner/upload_async_message HTTP/1.1" 200 -
>> "http://localhost:8080/"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:11 +0200] "GET /history HTTP/1.1" 200 -
>> "http://localhost:8080/tool_runner/upload_async_message"; "Mozilla/5.0
>> (X11; Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:11 +0200] "POST /root/user_get_usage
>> HTTP/1.1" 200 - "http://localhost:8080/history"; "Mozilla/5.0 (X11;
>> Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:13 +0200] "GET
>> /tool_runner?tool_id=upload1 HTTP/1.1" 200 -
>> "http://localhost:8080/root/tool_menu"; "Mozilla/5.0 (X11; Ubuntu; Linux
>> x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:15 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:19 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:23 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:27 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:31 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:35 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:39 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:43 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>> 127.0.0.1 - - [22/Feb/2012:09:48:47 +0200] "POST
>> /root/history_item_updates HTTP/1.1" 200 -
>> "http://localhost:8080/history"; "Mozilla/5.0 (X11; Ubuntu; Linux x86_64;
>> rv:10.0.2) Gecko/20100101 Firefox/10.0.2"
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client. To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>
>> http://lists.bx.psu.edu/
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>
>  http://lists.bx.psu.edu/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to