Sorry to see you're still experiencing problems.  Based on the issues you've 
encountered (as well as one or two others recently) I've spent some time 
re-working things to eliminate the need for installing mercurial to use a local 
tool shed.  We will build eggs for the mercurial package for the various 
versions of Python supported by Galaxy and include them in the distribution.  

I'm pretty close to having this finished, so it is likely that this will be 
available early next week.  

I'm not sure if this will fix the problems you're seeing, but at least it will 
eliminate one of the variables.

Greg Von Kuster

On Apr 19, 2012, at 5:02 AM, Paul-Michael Agapow wrote:

> [For those who came in late - I've installed a local toolshed, which allows 
> me to create repositories, but every time  I attempt to upload files, it 
> errors out with "TypeError: array item must be char". For those who come 
> after me, here's what I worked out thus far.]
> Greg asked:
>> Since you've tried uploading various files with no success, the problem is 
>> likely
>> to be caused by something specific to your environment - possibly the 
>> version of
>> the mercurial package you're using.  What version of Python are you running, 
>> and
>> what version of the mercurial package do you have installed with it?  Also, 
>> what
>> version of Galaxy do you have, and what database / version are you using?
> We're CentOS, an older flavour (4), but my Mercurial is up to data (2.1.2). 
> Python 2.6.4, Galaxy is 6799:40f1816d6857 (grabbed it fresh last week for 
> testing), running it with sqlite. However, the Mercurial is actually 
> installed local to the account I'm using, so I wonder if the toolshed is 
> getting confused with another version, although hg doesn't seem to be 
> installed on the system.
> Further investigations reveal that the files appear to be in the repo 
> (database/community_files). The error manifest in the middle of Mercurial, in 
> where it attempts to coerce a Unicode string into a character 
> array. (As there are some reported issues of Windows file names with Unicode 
> under Mercurial, and I'm uploading from a Windows machine, I used a Mac to 
> create a repo and add a file. Nope, same behaviour.) The Cistrome galaxy fork 
> (
>  mentions occasional similar errors.
> I check the Mercurial installation:
> % hg --version
> Mercurial Distributed SCM (version 2.1.2+10-4d875bb546dc)
> ...
> % hg debuginstall
> Checking encoding (UTF-8)...
> Checking installed modules 
> (/home/f0/paul/Installed/lib/python2.6/site-packages/mercurial)...
> Checking templates 
> (/home/f0/paul/Installed/lib/python2.6/site-packages/mercurial/templates)...
> Checking commit editor...
> Checking username...
> No problems detected
> (Actually, I was missing a username and a user ~/.hgrc file. But making that, 
> it passes. Error still persists.)
> Work continues.
> ----
> Paul Agapow (
> Bioinformatics, Health Protection Agency
> -----------------------------------------
> **************************************************************************
> The information contained in the EMail and any attachments is
> confidential and intended solely and for the attention and use of
> the named addressee(s). It may not be disclosed to any other person
> without the express authority of the HPA, or the intended
> recipient, or both. If you are not the intended recipient, you must
> not disclose, copy, distribute or retain this message or any part
> of it. This footnote also confirms that this EMail has been swept
> for computer viruses, but please re-sweep any attachments before
> opening or saving. HTTP://
> **************************************************************************
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

Reply via email to