On Aug 2, 2012, at 1:59 PM, Rui Wang wrote:

> Hi All,
> 
> we are installing a local galaxy instance but we met something puzzling.
> 
> we are running galaxy on cent os 5.x and python 2.6.1. when we tried to upload
> data, it failed with the message 
> 
>  
> *************************************************************************
> Dataset generation errors
>  
> Dataset 5: brain.fa
> Tool execution generated the following error message:
>  
> /usr/usc/python/2.6.1/lib/python2.6/site-packages/pytz/tzinfo.py:5: 
> DeprecationWarning: the sets module is deprecated from sets import Set
> *************************************************************************
> 
> However, when we tried to use the galaxy version tied to the OS, which is 
> 2.4.3, we
> were able to upload successfully. Did anyone have the same experience?
> 
> Any advice will be greatly appreciated.

Hi Rui,

I'd suggest upgrading your version of pytz with `easy_install --upgrade pytz`.  
Newer versions should correctly handle importing sets.

--nate

> 
> Thanks,
> Rui 
> 
> 
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
> 
>  http://lists.bx.psu.edu/


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to