Sure,

This is the least I can do. However, I do not know how to install a package from a simple XML, and without Tool Shed installed repository.


I will check that.

I have downloaded Galaxy for installation less than a week ago.

Matthias.


On Wed, 24 Apr 2013, Björn Grüning wrote:

Hi Matthias,

do you use the toolshed or the testtoolshed?
Can you please test the following repo and install:

testtoolshed.g2.bx.psu.edu/repos/bgruening/package_numpy_1_7

It also contains append_to and works for me. Also which version of
galaxy do you use?

Thanks!
Bjoern

Dear everyone,

I finally got the answer. The "append_to" does not seem do work in the
"tool_dependencies.xml":

---
<environment_variable name="PYTHONPATH"
action="append_to">$REPOSITORY_INSTALL_DIR</environment_variable>
---
does not insert anything, while:
---
<environment_variable name="PYTHONPATH"
action="set_to">$REPOSITORY_INSTALL_DIR</environment_variable>
---
updates the correct "env.sh" and "INSTALLATION.log" files.

Weird.

Many thanks for your help.

Matthias.


On Tue, 23 Apr 2013, Björn Grüning wrote:

Hi Matthias,

Dear Björn,
Maybe the problem is here. I cannot find neither "tool_deps", nor
"env.sh".
The install is fresh from yesterday... I should check why I did not
generate these files.
By the way, if "env.sh" is sourced right before my script, I should see
the updated PYTHONPATH in the result of the command "env > $outputFile",
no?

Yes :)
The tool_deps directory is set in universe_wsgi.ini under:
tool_dependency_dir = ./tool_deps/

Ciao,
Bjoern

Many thanks,
Matthias.


On Tue, 23 Apr 2013, Björn Grüning wrote:

Hi Matthias,

PYTHONPATH will not be changed globally.
It's only changed during execution of your tool.
Have a look under ./tool_deps/.../.../.../s_mart/ there is a file called
env.sh with your PYTHONPATH.
That file is executed before your command

<command>env > $outputFile</command>

is executed.
Hope that helps,
Bjoern



Dear everyone,

I have spent hours trying to set environment variable in Galaxy. I am
managing the "s_mart" repos (you can check it if you wish), and I created
the simple files "test.xml" which prints the environment variables:
---
<tool id="test" name="test">
     <description>This is a test.</description>
     <requirements>
         <requirement type="set_environment">PYTHONPATH</requirement>
     </requirements>
     <command>env > $outputFile</command>
     <outputs>
             <data name="outputFile" format="txt" label="output test
file"/>
     </outputs>
     <help>This is a test.</help>
</tool>
---

and "tool_dependencies.xml", which appends something to the PYTHONPATH
variable.:
---
<?xml version="1.0"?>
<tool_dependency>
     <set_environment version="1.0">
         <environment_variable name="PYTHONPATH"
action="append_to">$REPOSITORY_INSTALL_DIR</environment_variable>
     </set_environment>
</tool_dependency>
---
As you guess, I cannot see anything added in the PYTHONPATH variable. I
have tried to append INSTALL_DIR and even "/tmp". None worked.

Do you have any suggestion for me?

Many thanks to you all,

Matthias.
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/








___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to