Hi.   I am new to the Galaxy forum and I am trying to setup a new local
Galaxy instance with MySQL on RH6.2 x86_64.

On a newly installed OS node, using the hg clone command (hg clone
https://bitbucket.org/galaxy/galaxy-dist#stable) which gets the current
Galaxy 20130603 image, I am getting the following errors when running
  File "build/bdist.linux-x86_64-ucs4/egg/MySQLdb/cursors.py", line 173, in
    self.errorhandler(self, exc, value)
  File "build/bdist.linux-x86_64-ucs4/egg/MySQLdb/connections.py", line 36,
in defaulterrorhandler
    raise errorclass, errorvalue
OperationalError: (OperationalError) (1170, "BLOB/TEXT column 'slug' used
in key specification without a key length") 'CREATE INDEX ix_history_slug
ON history (slug)' ()

Reading the forum, someone stated it can be bypass by running the CREATE

mysql> CREATE INDEX ix_history_slug ON history (slug(1000));
Query OK, 0 rows affected (0.09 sec)
Records: 0  Duplicates: 0  Warnings: 0

When trying to run.sh again after the CREATE INDEX, will get this error:
  File "/gpfs/gpfs2/home/galaxyadmin25/galaxy-dist/lib/galaxy/app.py", line
52, in __init__
    create_or_verify_database( db_url, kwargs.get( 'global_conf', {} ).get
( '__file__', None ), self.config.database_engine_options, app=self )
 line 107, in create_or_verify_database
    % ( db_schema.version, migrate_repository.versions.latest,
config_arg ) )
Exception: Your database has version '29' but this code expects version
'115'.  Please backup your database and then migrate the schema by running
'sh manage_db.sh upgrade'.

So try to run the "sh manage_db.sh upgrade' now will get this error:
$ sh manage_db.sh upgrade
Traceback (most recent call last):
  File "./scripts/manage_db.py", line 13, in <module>
    from migrate.versioning.shell import main
 line 12, in <module>
    from migrate.versioning import api
 line 33, in <module>
    from migrate.versioning import (repository, schema, version,
 line 13, in <module>
    from migrate.versioning import version, pathed, cfgparse
 line 10, in <module>
    from migrate.versioning import pathed, script
 line 11, in <module>
    from migrate.versioning.util import KeyedInstance
 line 7, in <module>
    from decorator import decorator
ImportError: No module named decorator

In some searches, there were tips of deleting the eggs directory and rerun
run.sh or use a python env.  Neither option worked.
Was not able to find anything meaningful about the decorator error.

Note:, I was able to get Galaxy up with MySQL using the Galaxy 788cd3d06541
image on a different node.  So I am thinking maybe it is the new 20130603
image that is giving me issues?

Commands used to get Galaxy up:
   Install mysql from yum repository [MySQL 5.1.52-1.el6_0.1]
   python version [2.6.6]

   Grant ALL PRIVILEGES galaxy_db.* TO  galaxy_user on localhostname with
   Images tested:

        *Copy of the galaxy-galaxy-dist-788cd3d06541.tar.bz2 image  Did not
   run the hg update command. [This worked]

        *hg clone stable of newest image [Failed]

   Update the universe_wsg.ini with the port, host, database_connection to

   Ran run.sh


Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to