Dear Galaxy hackers,

I'm having trouble with the tool test framework. I have a local
installation of a Galaxy Tool Shed (latest stable from the repository)
on my Linux server. I have an Apache proxy to my tool shed (per
http://wiki.galaxyproject.org/HostingALocalToolShed). The Tool Shed
seems to work fine. I'm able to create and maintain repositories and I'm
able to install tools from the Tool Shed from remote Galaxy instances.

Now I want to run the functional tests of the tools in the Tool Shed. I
do that by following the instructions on the wiki
(http://wiki.galaxyproject.org/AutomatedToolTests). It comes down to the
following commands:

----------------------------------------------------------------------
cd /opt/galaxy/galaxy-dist/
export
GALAXY_INSTALL_TEST_TOOL_SHED_API_KEY=2aeecfe2d9f28d0c5b6959a41886b5fd
export GALAXY_INSTALL_TEST_TOOL_SHED_URL=http://toolshed.galaxy.domain.org/
python lib/tool_shed/scripts/check_repositories_for_functional_tests.py
tool_shed_wsgi.ini
sh install_and_test_tool_shed_repositories.sh
----------------------------------------------------------------------

The second script (install_and_test_tool_shed_repositories.sh) fails
with the following error:

======================================================================
FAIL: install_repository_usearch
(install_and_test_tool_shed_repositories.functional.test_install_repositories.TestInstallRepository_usearch)
Install the repository usearch from http://toolshed.galaxy.domain.org/.
----------------------------------------------------------------------
Traceback (most recent call last):
  File
"/opt/galaxy/galaxy-dist/test/install_and_test_tool_shed_repositories/functional/test_install_repositories.py",
line 48, in test_install_repository
    self.do_installation( repository_dict )
  File
"/opt/galaxy/galaxy-dist/test/install_and_test_tool_shed_repositories/functional/test_install_repositories.py",
line 17, in do_installation
    self.install_repository( repository_info_dict )
  File
"/opt/galaxy/galaxy-dist/test/install_and_test_tool_shed_repositories/base/twilltestcase.py",
line 61, in install_repository
    self.visit_url( '%s/repository/preview_tools_in_changeset?%s' % (
tool_shed_url, preview_params ) )
  File
"/opt/galaxy/galaxy-dist/test/install_and_test_tool_shed_repositories/base/twilltestcase.py",
line 112, in visit_url
    ( return_code, url, ', '.join( str( code ) for code in allowed_codes ) )
AssertionError: Invalid HTTP return code 404 for
http://toolshed.galaxy.domain.org//repository/preview_tools_in_changeset?repository_id=3651c288c4818b12&changeset_revision=095baaf5d877,
allowed codes: 200
----------------------------------------------------------------------

(I've changed twilltestcase.py to also print the URL that is being
browsed.) This is were it get's weird. The HTTP 404 response code
indicates that the page was not found. However, when I browse to that
URL, it works fine! What's more, when I try to access that page with
`wget` from the same machine the HTTP response code is 200:

----------------------------------------------------------------------
wget
http://toolshed.galaxy.domain.org//repository/preview_tools_in_changeset?repository_id=3651c288c4818b12&changeset_revision=095baaf5d877
...
HTTP request sent, awaiting response... 200 OK
...
----------------------------------------------------------------------

When I use the Tool Shed URL http://localhost:9009/ instead, I get a
similar error, only the return code is 500 instead of 404. I suspect
that the HTTP return code returned by the Python module that returns it
(Mechanize?) is invalid. I found a note about this error on the wiki
(http://wiki.galaxyproject.org/Admin/Running%20Tests):

"Note: If you have another version of paste installed in your
PYTHONPATH, it can cause problems running the functional tests. Many
tests will error (instead of passing/failing) because of an HTML code
500 where a 200 was expected. There are two workarounds for this:
uninstall paste or use virtualenv. "

The thing is, I do not have another version of Paste installed. What can
I do to fix this error?

Regards,
Serrano Pereira
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to