While problems are been solved in my other Galaxy instance (MAC OSX), I
tried to install Galaxy on local Linux machine running Ubuntu 12.04.

Surprisingly, seems I have been able to get Galaxy toolshed work. The
problem I have now is that I'm trying to run a published workflow, named '
Detrprok_wf <>', that
requires S-Mart installed  and   Detrprok scripts installed. Both of them
are installed, however although I've also been able to import the
corresponding wokflow  'Detrprok_wf', seems there is something wrong. See
attached files.



Thanks for your help, Bernardo

Command and actions up to now:

python --version
hg clone -v https://bitbucket.org/galaxy/galaxy-dist/
cd galaxy-dist
hg update stable
sh run.sh

#7. Workflow installation instructions
#The workflow should be run on a local Galaxy instance or one hosted on a
distant server. Refer to the tutorial (
http://wiki.galaxyproject.org/Admin/Get_Galaxy) for creation of a #Galaxy
instance. As the workflow has several steps running in parallel, the Galaxy
instance should use a database management system supporting concurential
access such as #postgreSQL, instead of the default SQLite system. The
DETR'PROK pipeline is obtained from the Galaxy main tool shed (
http://toolshed.g2.bx.psu.edu/), or my experiment (http://#
www.myexperiment.org), searching by name "detrprok_wf", and should be
installed by the Galaxy instance administrator. DETR'PROK requires
installation of the S-MART toolbox [13] and 3the "detrprok_scripts", both
available in the Galaxy main tool shed.

done # replace admin = none by admin = popn...@gmail.com in
'universe_wsgi.ini' file
lets see if this is not essential # postgreSQL installation (

done # The DETR'PROK pipeline is obtained from the Galaxy main tool shed (

done ## DETR'PROK requires installation of the S-MART toolbox [13] and the

# S-MART needs the folowing packages
R --slave --no-save --no-restore --quiet -e 'if("RColorBrewer" %in%
rownames(installed.packages()) == FALSE){install.packages("RColorBrewer",
repos = c("http://cran.rstudio.com/";), dependencies = TRUE)}'
R --slave --no-save --no-restore --quiet -e 'if("Hmisc" %in%
rownames(installed.packages()) == FALSE){install.packages("Hmisc", repos =
c("http://cran.rstudio.com/";), dependencies = TRUE)}'

# set 'tool_dependency_dir'
mkdir tool_dependency_dir
# http://wiki.g2.bx.psu.edu/Admin/Config/Tool%20Dependencies
tool_dependency_dir = /home/usuario/tool_dependency_dir

# install 'detrprok_wf' nad from 'repository actions' import workflow to
NOTE -> Workflow Detrprok_wf imported successfully. The following tools
required by this workflow are missing from this Galaxy instance: name:
bam_to_sam, id: BAM-to-SAM.

done #  install 'bam_to_sam'
Install S-MART dependencies


*Bernardo Bello Ortí*

PhD student


Campus de Bellaterra-Universitat Autònoma de Barcelona

Edifici CReSA

08193  Bellaterra (Barcelona, Spain)

Tel.: 647 42 52 63 *www.cresa.es <http://www.cresa.es>  *
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to