This is not what I suggested, I said

Rscript_wrapper.sh
/Users/bbelfio1/galaxy-dist/tools/pathview/Pathview.R $genedata $pathwayid $species $output

replacing $genedata $pathwayid $species $output with meaningful arguments




On 04/28/2014 04:29 PM, Bradley Belfiore wrote:
Yes when running in command line I get:

bravo:galaxy-dist bbelfio1$ Rscript
/Users/bbelfio1/galaxy-dist/tools/pathview/Pathview.R

Error in value[[3L]](cond) :

   failed to read experimental design data: cannot open the connection

Calls: tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>

In addition: Warning message:

In file(file, "rt") : cannot open file 'NA': No such file or directory

Execution halted



On Mon, Apr 28, 2014 at 10:19 AM, Peter Cock <p.j.a.c...@googlemail.com
<mailto:p.j.a.c...@googlemail.com>> wrote:

     > On 04/28/2014 03:58 PM, Bradley Belfiore wrote:
     >>
     >> The initial error now seems to be taken care of and now am
    getting this
     >> message on attempting to run tool:
     >>
     >> File
    "/Users/bbelfio1/galaxy-dist/lib/galaxy/jobs/runners/__init__.py",
     >> line 153, in prepare_job
     >>      job_wrapper.runner_command_line = self.build_command_line(
     >> job_wrapper, include_metadata=include_metadata,
     >> include_work_dir_outputs=include_work_dir_outputs )
     >>    File
    "/Users/bbelfio1/galaxy-dist/lib/galaxy/jobs/runners/__init__.py",
     >> line 176, in build_command_line
     >>      return build_command( self, job_wrapper,
     >> include_metadata=include_metadata,
     >> include_work_dir_outputs=include_work_dir_outputs )
     >>    File
    "/Users/bbelfio1/galaxy-dist/lib/galaxy/jobs/command_factory.py",
     >> line 19, in build_command
     >>      commands_builder =
    CommandsBuilder(job_wrapper.get_command_line())
     >>    File
    "/Users/bbelfio1/galaxy-dist/lib/galaxy/jobs/command_factory.py",
     >> line 109, in __init__
     >>      commands = initial_command.rstrip("; ")
     >> AttributeError: 'NoneType' object has no attribute 'rstrip'
     >>

    This is still breaking inside Galaxy, before ever trying to run your
    scripts. There is likely still a problem in your XML.

    On Mon, Apr 28, 2014 at 3:08 PM, Hans-Rudolf Hotz <h...@fmi.ch
    <mailto:h...@fmi.ch>> wrote:
     > again, have you tried running your Rscript outside of Galaxy
    called by
     > Rscript_wrapper.sh ?
     >

    This is an important question :)

    Also, please remember to CC the mailing list and not just reply
    to the previous email's sender only.

    Thanks,

    Peter


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to