Can you please clarify if starting galaxy worked when you did:

. ./galaxy_env/bin/activate
cd galaxy_dist
sh run.sh

If it didn't, activate the python environment and run:

pip-2.6 install pycrypto
- or -
pip install pycrypto

If I recall correctly, the init script shipped with Galaxy does not activate 
the python environment.
I modified the init script to issue a login sudo in order to source the 
environment.  In .bashrc, I have it source the python environment.  This 
ensures that the python environment is always activated before galaxy is 
started regardless of how I start it.

Iyad Kandalaft
Bioinformatics Programmer
Microbial Biodiversity Bioinformatics
Science & Technology Branch
Agriculture & Agri-Food Canada
iyad.kandal...@agr.gc.ca | (613) 759-1228
From: galaxy-dev-boun...@lists.bx.psu.edu [galaxy-dev-boun...@lists.bx.psu.edu] 
on behalf of Eleanor Morgan [e.mor...@curtin.edu.au]
Sent: July 16, 2014 10:35 PM
To: galaxy-dev@lists.bx.psu.edu
Subject: [galaxy-dev] Unable to update to latest version of galaxy

Hi all,

I am new to galaxy.  We have a local install that we intend to turn into a 
production server at some stage.  We initially installed galaxy using the April 
2014 version.  We set up a Virtual Python Environment following the 
instructions set out on this page:


When I updated to the June version of galaxy and tried to start up the server 
using the recommended shell script placed in /etc/init.d I got the following 
error message:

Starting galaxy...

Some eggs are out of date, attempting to fetch...

Traceback (most recent call last):

  File "./scripts/fetch_eggs.py", line 37, in <module>

    c.resolve() # Only fetch eggs required by the config

  File "/galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", line 345, in resolve


  File "/galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", line 195, in resolve

    return self.version_conflict( e.args[0], e.args[1] )

  File "/galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", line 226, in 

    r = pkg_resources.working_set.resolve( ( dist.as_requirement(), ), env, 
egg.fetch )

  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 550, in resolve

    raise VersionConflict(dist,req) # XXX put more info here

pkg_resources.VersionConflict: (pycrypto 2.0.1 
(/usr/lib64/python2.6/site-packages), Requirement.parse('pycrypto>=2.1,!=2.4'))

Fetch failed.


This error message implies that I need to update pycrypto on our system, but my 
understanding is that the virtual python environment takes care of these sorts 
of dependencies. Can someone please advise?  Here are two series of commands 
that I tried to start the system:

First attempt:
sudo bash
/etc/init.d/galaxy stop
su - galaxy
cd /galaxy/galaxy-dist
hg pull
hg update latest_2014.06.02
/etc/init.d/galaxy start

After galaxy start failed I tried:
su – galaxy
cd /galaxy
. ./galaxy_env/bin/activate
cd galaxy_dist
sh run.sh

I also tried reinstalling the virtual environment to no avail.


Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to