Hi Eleanor

I was running into the same problem when I did the updates for our servers (from release_2013.11.04 to release_2014.04.14), eg:

...
pkg_resources.VersionConflict: (pycrypto 2.0.1 (/usr/lib64/python2.6/site-packages), Requirement.parse('pycrypto>=2.1,!=2.4'))
Fetch failed.


I solved it by deleting the contents of ~/galaxy_dist/eggs/ and fetched all eggs again (not just the new/updated ones). This somehow solved the problem, by using the (re-fetched) 'pycrypto' from ~/galaxy_dist/eggs/ instead of the one provided by the system.



Regards, Hans-Rudolf







On 07/17/2014 04:35 AM, Eleanor Morgan wrote:
Hi all,

I am new to galaxy.  We have a local install that we intend to turn into
a production server at some stage.  We initially installed galaxy using
the April 2014 version.  We set up a Virtual Python Environment
following the instructions set out on this page:

https://wiki.galaxyproject.org/Admin/Config/Performance/ProductionServer#Use_a_clean_environment

When I updated to the June version of galaxy and tried to start up the
server using the recommended shell script placed in /etc/init.d I got
the following error message:

Starting galaxy...

Some eggs are out of date, attempting to fetch...

Traceback (most recent call last):

   File "./scripts/fetch_eggs.py", line 37, in <module>

     c.resolve() # Only fetch eggs required by the config

   File "/galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", line 345, in
resolve

     egg.resolve()

   File "/galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", line 195, in
resolve

     return self.version_conflict( e.args[0], e.args[1] )

   File "/galaxy/galaxy-dist/lib/galaxy/eggs/__init__.py", line 226, in
version_conflict

     r = pkg_resources.working_set.resolve( ( dist.as_requirement(), ),
env, egg.fetch )

   File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 550,
in resolve

     raise VersionConflict(dist,req) # XXX put more info here

pkg_resources.VersionConflict: (pycrypto 2.0.1
(/usr/lib64/python2.6/site-packages),
Requirement.parse('pycrypto>=2.1,!=2.4'))

Fetch failed.

…done.


This error message implies that I need to update pycrypto on our system,
but my understanding is that the virtual python environment takes care
of these sorts of dependencies. Can someone please advise?  Here are two
series of commands that I tried to start the system:


First attempt:

sudo bash

/etc/init.d/galaxy stop

su - galaxy

cd /galaxy/galaxy-dist

hg pull

hg update latest_2014.06.02

exit

/etc/init.d/galaxy start


After galaxy start failed I tried:

su – galaxy

cd /galaxy

. ./galaxy_env/bin/activate

cd galaxy_dist

sh run.sh


I also tried reinstalling the virtual environment to no avail.


Regards,

Eleanor





___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
   http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
   http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to