On Tue, Oct 7, 2014 at 1:47 AM, Isabelle Phan
<isabelle.p...@seattlebiomed.org> wrote:
> Hello,
> I installed clustalomega from the galaxy main toolshed using the admin
> interface of our local galaxy install.
> When I run the tool, I get this message:
> Dataset generation errors
>         Dataset 55: co_alignment.fasta
>                 Tool execution generated the following error message:
>                     Error invoking command:
> clustalo --force --threads=1 --maxnumseq=300000 --maxseqlen=15000 -o
> /opt/galaxy-dist/database/files/000/dataset_158.dat -l
> /opt/galaxy-dist/database/files/000/dataset_159.dat -v -i
> /opt/galaxy-dist/database/files/000/dataset_153.dat
> [Errno 2] No such file or directory
> I've tried reloading my input file, reloading the tool's configuration,
> resetting the metadata on the clustalomega repository, deleting the tool
> completely and re-installing. No luck. If I try to rerun the job again, I
> get non-sensical errors that seem to originate from other tools, as if the
> database was completely garbled. Each of those tools work fine. Only
> clustalomega behaves oddly.
> I have no access to our galaxy server, so any solution would have to be
> implemented from the admin interface.
> thanks for any hints,
> Isabelle

Hi Isabelle,

I am guessing you used this ToolShed repository:


As far as I can see, this does not automatically install the clustalo
binary, which would explain "[Errno 2] No such file or directory".
The (incomplete and out of date) README file suggests you are
expected to manually compile it from the bundled copy of the
Clustal Omega source code.

If the only access you have to modify the server is via the Galaxy
admin interface, you will not be able to fix this.

As it stands right now, this ToolShed repository would not get a
gold star approval rating :(

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to