Thank you all for the help! Its all running smoothly now.

Best,
Nathan

On Wed, Dec 31, 2014 at 3:50 PM, Björn Grüning <bjoern.gruen...@gmail.com>
wrote:

> Hi Nathan,
>
> please try the following.
>
> ln -s /path/to/your/shed_tools/samtools/0.1.19/devteam/what/ever/
> /path/to/your/shed_tools/samttools/default
>
> The important part is that it is samtools < 1.0 and that the default
> link is a link to the folder in which you find the env.sh file.
>
> I hope this will tell Galaxy how to find samtools for you. Otherwise
> simply put the samtools binary into your $PATH.
>
> Cheers and happy new year!
> Bjoern
>
> Am 31.12.2014 um 19:49 schrieb Nathan Kipniss:
> > Hi All,
> >
> > New to galaxy here. I'm having an issue uploading bam files into a local
> > instance of galaxy. I understand that it requires samtools, and I
> installed
> > the appropriate dependency from the toolshed. However, I get the
> following
> > error:
> >
> > Traceback (most recent call last):
> >   File "/home/galaxy/galaxy-dist/tools/data_source/upload.py", line
> > 407, in <module>
> >     __main__()
> >   File "/home/galaxy/galaxy-dist/tools/data_source/upload.py", line
> > 396, in __main__
> >     add_file( dataset, registry, json_file, output_path )
> >   File "/home/galaxy/galaxy-dist/tools/data_source/upload.py", line
> > 324, in add_file
> >     if link_data_only == 'copy_files' and
> > datatype.dataset_content_needs_grooming( output_path ):
> >   File "/home/galaxy/galaxy-dist/lib/galaxy/datatypes/binary.py", line
> > 147, in dataset_content_needs_grooming
> >     version = self._get_samtools_version()
> >   File "/home/galaxy/galaxy-dist/lib/galaxy/datatypes/binary.py", line
> > 129, in _get_samtools_version
> >     output = subprocess.Popen( [ 'samtools' ], stderr=subprocess.PIPE,
> > stdout=subprocess.PIPE ).communicate()[1]
> >   File "/usr/lib/python2.7/subprocess.py", line 710, in __init__
> >     errread, errwrite)
> >   File "/usr/lib/python2.7/subprocess.py", line 1327, in _execute_child
> >     raise child_exception
> > OSError: [Errno 2] No such file or directory
> >
> >
> > Which leads me to believe something is wrong with the install (can't
> > find samtools). The dependency directory is also set. Is there another
> > step I'm missing, or is it better to not install dependencies via the
> > toolshed?
> >
> > Best,
> > Nathan Kipniss
> >
> >
> >
> > ___________________________________________________________
> > Please keep all replies on the list by using "reply all"
> > in your mail client.  To manage your subscriptions to this
> > and other Galaxy lists, please use the interface at:
> >   https://lists.galaxyproject.org/
> >
> > To search Galaxy mailing lists use the unified search at:
> >   http://galaxyproject.org/search/mailinglists/
> >
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to