Hi, Jose

Our next cycle includes some updates to the resubmission/hda-serialization
code that's mentioned in your stack trace.

You can try two things:
1) You can wait for us to officially publish our next stable release
(15.05) at the beginning of next month and then update your instance.
2) You can update *now* to the github version that *will be* our 15.05
release: https://github.com/galaxyproject/galaxy/tree/release_15.05

We are still stabilizing 15.05 and not all bug fixes have been committed,
but it may be the best option if you need to get past this problem quickly.

If you're unable to do one of the above or are still having issues after
doing one of them, let me know and we can work on it further.

Carl


On Mon, Apr 27, 2015 at 4:28 AM, Jose Juan Almagro Armenteros <
jjalma...@gmail.com> wrote:

> Hello Dannon,
>
> This is the log when a job is executed:
>
> galaxy.jobs DEBUG 2015-04-24 17:25:27,266 (9568) Working directory for
> job is:
> /steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568
> galaxy.jobs.handler DEBUG 2015-04-24 17:25:27,313 (9568) Dispatching to
> local runner
> galaxy.jobs DEBUG 2015-04-24 17:25:27,600 (9568) Persisting job
> destination (destination id: local)
> galaxy.jobs.handler INFO 2015-04-24 17:25:27,686 (9568) Job dispatched
> galaxy.jobs.runners DEBUG 2015-04-24 17:25:28,465 (9568) command is:
> python
> /steno-internal/projects/galaxy/galaxy-dist/tools/table_gen/generator.py
> "/steno-internal/projects/galaxy/galaxy-dist/database/files/021/dataset_21041.dat"
> "1"; return_code=$?; python
> /steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/set_metadata_MH6prK.py
> /steno-internal/projects/galaxy/galaxy-dist/database/tmp/tmpw80FFi
> /steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/galaxy.json
> /steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/metadata_in_HistoryDatasetAssociation_14967_7w0ALE,/steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/metadata_kwds_HistoryDatasetAssociation_14967_uH3ZBP,/steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/metadata_out_HistoryDatasetAssociation_14967_5iEavP,/steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/metadata_results_HistoryDatasetAssociation_14967_6FT2qV,/steno-internal/projects/galaxy/galaxy-dist/database/files/021/dataset_21041.dat,/steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/metadata_override_HistoryDatasetAssociation_14967_iOPJoQ;
> sh -c "exit $return_code"
> galaxy.jobs.runners.local DEBUG 2015-04-24 17:25:28,475 (9568) executing
> job script:
> /steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/galaxy_9568.sh
> galaxy.jobs DEBUG 2015-04-24 17:25:28,617 (9568) Persisting job
> destination (destination id: local)
> galaxy.jobs.runners.local DEBUG 2015-04-24 17:25:31,960 execution
> finished:
> /steno-internal/projects/galaxy/galaxy-dist/database/job_working_directory/009/9568/galaxy_9568.sh
> galaxy.datatypes.metadata DEBUG 2015-04-24 17:25:32,207 loading metadata
> from file for: HistoryDatasetAssociation 14967
> galaxy.jobs INFO 2015-04-24 17:25:34,775 Collecting job metrics for
> <galaxy.model.Job object at 0x7f3154cacad0>
> galaxy.jobs DEBUG 2015-04-24 17:25:34,799 job 9568 ended
> galaxy.datatypes.metadata DEBUG 2015-04-24 17:25:34,800 Cleaning up
> external metadata files
>
>
>
>
>
>
> I am not sure at all but I think this is the internal error that I got
> with the history panel problem:
>
> 130.225.125.174 - - [24/Apr/2015:15:22:19 +0200] "GET
> /api/histories/32c70b5011288952/contents HTTP/1.1" 500 - "
> http://galaxy.bric.dk/history/view_multiple"; "Mozilla/5.0 (X11; Linux
> x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120
> Safari/537.36"
> galaxy.web.framework.decorators ERROR 2015-04-24 15:22:20,033 Uncaught
> exception in exposed API method:
> Traceback (most recent call last):
>   File
> "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/web/framework/decorators.py",
> line 251, in decorator
>     rval = func( self, trans, *args, **kwargs)
>   File
> "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/webapps/galaxy/api/history_contents.py",
> line 105, in index
>     hda_dict = self.hda_serializer.serialize_to_view( trans, content,
> view=view )
>   File
> "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/managers/base.py",
> line 621, in serialize_to_view
>     return self.serialize( trans, item, all_keys )
>   File
> "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/managers/hdas.py",
> line 453, in serialize
>     serialized = super( HDASerializer, self ).serialize( trans, hda, keys )
>   File
> "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/managers/base.py",
> line 566, in serialize
>     returned[ key ] = self.serializers[ key ]( trans, item, key )
>   File
> "/steno-internal/projects/galaxy/galaxy-dist/lib/galaxy/managers/hdas.py",
> line 403, in <lambda>
>     'resubmitted'   : lambda t, i, k: i._state ==
> t.app.model.Dataset.states.RESUBMITTED,
> AttributeError: 'Bunch' object has no attribute 'RESUBMITTED'
>
>
> Thanks a lot for your help!
>
> Regards,
>
> Jose
>
>
> 2015-04-24 17:16 GMT+02:00 Dannon Baker <dannon.ba...@gmail.com>:
>
>> Hi Jose,
>>
>> Can you review (and share, maybe) the relevant part of the logs from when
>> you attempt to execute a job?  It'd be worth it, if you still have the
>> logs, to know what the "Internal Server Error" indicated in your first
>> message was, as well.
>>
>> -Dannon
>>
>> On Fri, Apr 24, 2015 at 11:00 AM Jose Juan Almagro Armenteros <
>> jjalma...@gmail.com> wrote:
>>
>>> Hi again,
>>>
>>> Now it is working, I just went back to the previous version and updated
>>> it again. All is okay except that the job table in the postgresql database
>>> is empty and is not being updated with new jobs (the problem is only with
>>> this table). I run manage_db.sh upgrade but nothing happened.
>>>
>>> Do you know what could be causing this?
>>>
>>> Thank you again!
>>>
>>> Best regards,
>>>
>>> Jose
>>>
>>> 2015-04-24 14:22 GMT+02:00 Jose Juan Almagro Armenteros <
>>> jjalma...@gmail.com>:
>>>
>>>> Hello all,
>>>>
>>>> I have updated my Galaxy distribution today to the latest version 15.03
>>>> and the history panel is not being shown. The history seems to be there but
>>>> Galaxy can't display the datasets.  Even if I create a new history and I
>>>> run a tool the dataset is not shown. It is just displayed an error which
>>>> says: "An error occurred while getting updates from the server..." and the
>>>> details shows this:
>>>>
>>>> {
>>>>   "agent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, 
>>>> like Gecko) Chrome/37.0.2062.120 Safari/537.36",
>>>>   "url": 
>>>> "http://galaxy.bric.ku.dk/history/view_multipl/api/histories/782c6cc7ec4cfd9f/contents";,
>>>>   "data": "",
>>>>   "options": {
>>>>     "data": {},
>>>>     "silent": true,
>>>>     "parse": true,
>>>>     "emulateHTTP": false,
>>>>     "emulateJSON": false
>>>>   },
>>>>   "xhr": {
>>>>     "readyState": 4,
>>>>     "responseText": "{\"err_msg\": \"Uncaught exception in exposed API 
>>>> method:\", \"err_code\": 0}",
>>>>     "responseJSON": {
>>>>       "err_msg": "Uncaught exception in exposed API method:",
>>>>       "err_code": 0
>>>>     },
>>>>     "status": 500,
>>>>     "statusText": "Internal Server Error",
>>>>     "responseHeaders": {
>>>>       "Date": "Fri, 24 Apr 2015 12:09:40 GMT\r",
>>>>       "cache-control": "max-age=0,no-cache,no-store\r",
>>>>       "Transfer-Encoding": "chunked\r",
>>>>       "Server": "PasteWSGIServer/0.5 Python/2.7.3\r",
>>>>       "Connection": "close\r",
>>>>       "x-frame-options": "SAMEORIGIN\r",
>>>>       "content-type": "application/json\r"
>>>>     }
>>>>   },
>>>>   "source": [],
>>>>   "user": {
>>>>     "username": "jose",
>>>>     "quota_percent": 0,
>>>>     "total_disk_usage": 101352147,
>>>>     "nice_total_disk_usage": "96.7 MB",
>>>>     "email": "jjalma...@gmail.com",
>>>>     "is_admin": true,
>>>>     "tags_used": [],
>>>>     "model_class": "User",
>>>>     "id": "72ad249754f05d26"
>>>>   }
>>>> }
>>>>
>>>> Do you have any idea what could go wrong?
>>>>
>>>> Thank you and best regards,
>>>>
>>>> Jose
>>>>
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>>   https://lists.galaxyproject.org/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>>   http://galaxyproject.org/search/mailinglists/
>>
>>
>
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to