Hi, Ata Roudgar

It is indeed a bug. Thank you very much for the excellent and *helpful*
report!

We now have a fix for this on the release_15.05 branch of the github
repository:
https://github.com/galaxyproject/galaxy/commit/13a40b3ef206f8662a49dfd06fbbc05b026f8c64

It should fix the issue but please let us know if it doesn't. Sorry for the
trouble.


On Fri, Jul 3, 2015 at 3:46 PM, Ata Roudgar <aroud...@sfu.ca> wrote:

>
> Hi,
>
> I am a computer cluster admin and I am trying to install galaxy on our
> cluster. I used galaxy-release_15.05 and because we need to serve Galaxy at
> a sub directory, e.g. irida-galaxy I modified the options prefix and
> cookie_path in the galaxy configuration file as follow:
>
> prefix = /irida-galaxy
> filter-with = proxy-prefix
> cookie_path = /irida-galaxy
>
> We use apache as an interface with the Following configuration:
>
> <Proxy http://localhost:9010>
>     Order deny,allow
>     Allow from all
> </Proxy>
>
> RewriteRule ^/irida-galaxy$ /irida-galaxy/ [R]
> RewriteRule ^/irida-galaxy/static/style/(.*)
> /home/irida/galaxy-dist/static/june_2007_style/blue/$1 [L]
> RewriteRule ^/irida-galaxy/static/scripts/(.*)
> /home/irida/galaxy-dist/static/scripts/packed/$1 [L]
> RewriteRule ^/irida-galaxy/static/(.*) /home/irida/galaxy-dist/static/$1
> [L]
> #RewriteRule ^/irida-galaxy/favicon.ico
> /home/irida/galaxy-dist/static/favicon.ico [L]
> RewriteRule ^/irida-galaxy/robots.txt
> /home/irida/galaxy-dist/static/robots.txt [L]
> RewriteRule ^/irida-galaxy(.*) http://localhost:9010$1 [P]
>
>
> Everything works fairly good. Now I want to create a Dataset Pairs. first
> I uploads some fastaq files, e.g.,
>
> a_1.fastaq
> a_2.fastaq
> b_1.fastaq
> b_2.fastaq
> c_1.fastaq
> c_2.fastaq
>
> then I choose: "Build List of Dataset Pairs" (See Fig-1 attached)
>
> There is a window appears on my screen with the title: Create a collection
> of paired datasets. Now I am able to choose a name and save the paired
> collection. However, once I click on "Create list" buttons I receive a
> error message on top of the windows:
>
> "An error occurred While creating this collection: Not found
>
> See Fig-2 attached. To be able to search the cause of error I turn on the
> "Browser Consul" on my web browser and notice that the error is related to
> the following web form post:
>
>
>
> https://newrobson.westgrid.ca:8444/api/histories/4936629215c25989/contents/dataset_collections
>
>
> Which makes sense because such address do not exist. The address should be
>
>
> https://newrobson.westgrid.ca:8444/irida-galaxy/api/histories/4936629215c25989/contents/dataset_collections
>
> So the prefix (irida-galaxy) is missing before
> /api/histories...../dataset_collection
>
> Is it a bug or am I missing something?
>
> Please note that such error does not appear when I do not use prefix in my
> galaxy configration.
>
> Thanks for your time,
> Cheers,
> Ata
>
>
> ----
> Ata Roudgar
> Research Computing
> WestGrid Site
> IT Services
> Simon Fraser University
> Burnaby, British Columbia
> Canada  V5A 1S6
>
> phone: 778 782-8860
> fax:   778 782-4242
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to