Hi all

Thanks to a great effort by Dannon, we have solved the problem. Since I took the discussion off-list after his initial reply, I now owe you the solution:

My initial mistake was the change in the apache config file. I should have added:

            <Location "/api">
                Satisfy Any
                Allow from all
            </Location>

Since our Galaxy is not served from a sub directory (such as /galaxy) - D'OH !!


In the whole process, we identified a problem in the Galaxy code, which is now nicely patched:

https://github.com/galaxyproject/galaxy/pull/1003

Regards, Hans-Rudolf


On 10/22/2015 04:09 PM, Dannon Baker wrote:
My guess is that it has to do with the prefix there.  Is the Galaxy API
at galaxy-dev.fmi.ch/galaxy/api <http://galaxy-dev.fmi.ch/galaxy/api> or
galaxy-dev.fmi.ch/api <http://galaxy-dev.fmi.ch/api>?

On Thu, Oct 22, 2015 at 6:41 AM Hans-Rudolf Hotz <h...@fmi.ch
<mailto:h...@fmi.ch>> wrote:

    Hi

    We would like to start using BioBlend on our production servers (which
    use external authentication) as well.

    We have changed the apache conf file by adding

           <Location "/galaxy/api">
               Satisfy Any
               Allow from all
           </Location>



    Nevertheless, we still get the following error, when using one of the
    example scripts:


    $ python list_data_libraries.py galaxy-dev.fmi.ch
    <http://galaxy-dev.fmi.ch> ***************
    Initiating Galaxy connection
    Retrieving Data Library list
    Traceback (most recent call last):
        File "list_data_libraries.py", line 23, in <module>
          libraries = gi.libraries.get_libraries()
        File
    
"/****/lib/python2.6/site-packages/bioblend-0.6.1-py2.6.egg/bioblend/galaxy/libraries/__init__.py",
    line 216, in get_libraries
          libraries = Client._get(self, deleted=deleted)
        File
    
"/****/lib/python2.6/site-packages/bioblend-0.6.1-py2.6.egg/bioblend/galaxy/client.py",
    line 147, in _get
          raise ConnectionError(msg)
    bioblend.galaxy.client.ConnectionError: GET: error 401: '<!DOCTYPE HTML
    PUBLIC "-//IETF//DTD HTML 2.0//EN">\n<html><head>\n<title>401
    Authorization Required</title>\n</head><body>\n<h1>Authorization
    Required</h1>\n<p>This server could not verify that you\nare authorized
    to access the document\nrequested.  Either you supplied the
    wrong\ncredentials (e.g., bad password), or your\nbrowser doesn\'t
    understand how to supply\nthe credentials
    required.</p>....</body></html>\n', 0 attempts left: None
    $


    Is there anything else we need to change in the conf file, or do we have
    to do something different?



    Thank you very much for any help with this
    Hans-Rudolf



    --



    Hans-Rudolf Hotz, PhD
    Bioinformatics Support

    Friedrich Miescher Institute for Biomedical Research
    Maulbeerstrasse 66
    4058 Basel/Switzerland
    ___________________________________________________________
    Please keep all replies on the list by using "reply all"
    in your mail client.  To manage your subscriptions to this
    and other Galaxy lists, please use the interface at:
    https://lists.galaxyproject.org/

    To search Galaxy mailing lists use the unified search at:
    http://galaxyproject.org/search/mailinglists/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/mailinglists/

Reply via email to