Hi Scott,

I've recently hit the exact same problem. Have you had any success since
then with resolving this? I did some poking around and made a bit of
progress, but still no solution.

The Data Manager page under Run Data Manager Tools contains URLs like this:

https://galaxy.example.com/root?tool_id=toolshed.g2.bx.psu.edu%2Frepos%2Fdevteam%2Fdata_manager_fetch_genome_dbkeys_all_fasta%2Fdata_manager_fetch_genome_all_fasta_dbkey%2F0.0.1

Loading that URL results in an attempted load of:

https://galaxy.example.com/api/tools/toolshed.g2.bx.psu.edu%2Frepos%2Fdevteam%2Fdata_manager_fetch_genome_dbkeys_all_fasta%2Fdata_manager_fetch_genome_all_fasta_dbkey%2F0.0.1/build
?

Which results in a 404 error. I believe the escaping of the slashes is
accidental, as the they are in the path and not in parameters. Changing the
%2F to / as shown here:

https://galaxy.example.com/api/tools/toolshed.g2.bx.psu.edu/repos/devteam/data_manager_fetch_genome_dbkeys_all_fasta/data_manager_fetch_genome_all_fasta_dbkey/0.0.1/build
?

results in the URL being found and you get back a bunch of JSON about the
tool. I tried looking in the Galaxy code to see if I could quickly
determine where the /root controller is, but I wasn't successful. Perhaps
this is now enough information that one of the developers might be able to
help us.

-Will

On Mon, Apr 11, 2016 at 9:55 AM, Scott Szakonyi <scott.b.szakony...@nd.edu>
wrote:

> Hello,
>
> I'm having an odd problem after updating to the latest version of Galaxy.
> My users prepare data for analysis using data manager tools, such as
> "data_manager_bwa_mem_index_builder". When an attempt is made to run one of
> these tools, a pop up window opens stating "Tool request failed" and
> underneath "Uncaught error". I've pored over all the Galaxy system logs and
> can't find anything that might indicate what is happening. I've uninstalled
> and reinstalled the data manager tools, restarted both the Galaxy service
> and the server, to no avail. I get this same error with any installed data
> manager, yet all the standard tools are executing correctly and don't seem
> to be having any issues.
>
> If anyone can offer some insight or suggestions for resolving this issue,
> I'd be most appreciative.
>
> Best regards,
>
> --
> Scott B. Szakonyi
> Research Programmer
>
> *Center for Research Computing*
> 107 Information Technology Center
> Notre Dame, IN 46556
> http://crc.nd.edu
>
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   https://lists.galaxyproject.org/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
>



-- 
The information contained in this e-mail message or any attachment(s) may
be confidential and/or privileged and is intended for use only by the
individual(s) to whom this message is addressed.  If you are not the
intended recipient, any dissemination, distribution, copying, or use is
strictly prohibited.  If you receive this e-mail message in error, please
e-mail the sender at who...@lygos.com and destroy this message and remove
the transmission from all computer directories (including e-mail servers).

Please consider the environment before printing this email.
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to