Dear all,

Sorry to bring this up again, but I've been so far unable to solve
this problem.  After trying to install various combination of things
and looking further away from the Exception messages, I guess I have
located the cause of the problem.  It seems at least two dependencies
no longer exist on the server in a particular location.  These are two
more lines in the paster log file:

tool_shed.galaxy_install.install_manager ERROR 2016-06-03 14:47:14,508
Error installing tool dependency libpng version 1.6.7: Unable to
locate required tool shed repository named package_libpng_1_6_7 owned
by devteam with revision 3de32cd300a9.
tool_shed.galaxy_install.install_manager ERROR 2016-06-03 14:47:15,536
Error installing tool dependency freetype version 2.5.2: Unable to
locate required tool shed repository named package_freetype_2_5_2
owned by devteam with revision a65217367e4a.

So both of these are dependencies of cummeRbund.  Is there a
work-around for this kind of problem?  For example, if I installed
libpng and/or freetype using CentOS' package manager (i.e., rpm), will
it no longer search for this dependency?  Alternatively, is there
someone I should notify about this kind of problem in the Tool Shed?

Thank you for your help!


On Fri, Jun 3, 2016 at 1:08 AM, Raymond Wan <> wrote:
> Dear all,
> I'm trying to install a Galaxy tool (cummeRbund; the one from devteam)
> and I'm getting the following error during installation:
> -----
> Proxy Error
> The proxy server received an invalid response from an upstream server.
> The proxy server could not handle the request POST
> /admin_toolshed/prepare_for_install.
> Reason: Error reading from remote server
> -----
> In paster.log, I see this:
> ----------------------------------------
> Exception happened during processing of request from ('', 35420)
> Traceback (most recent call last):
>   File "/galaxy/galaxy/eggs/Paste-",
> line 1068, in process_request_in_thread
>     self.finish_request(request, client_address)
>   File "/usr/lib64/python2.6/", line 332, in finish_request
>     self.RequestHandlerClass(request, client_address, self)
>   File "/usr/lib64/python2.6/", line 628, in __init__
>     self.finish()
>   File "/usr/lib64/python2.6/", line 671, in finish
>     self.wfile.flush()
>   File "/usr/lib64/python2.6/", line 303, in flush
>     self._sock.sendall(buffer(data, write_offset, buffer_size))
> error: [Errno 32] Broken pipe
> ----------------------------------------
> Does this mean there's a problem on our side, or perhaps there is a
> file missing from the tool (or the connection to the Toolshed has a
> problem)?
> Any suggestions as to what I should look for?  I first tried 2 days
> ago and waited until now to try again -- still the same problem.
> Thank you!
> Ray
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to