The correct link is this: http://galaxy-dev.fmi.ch/tool_
runner/biomart?type=text&name=Homo%20sapiens%20genes%20%
28GRCh38.p5%29&URL=http://www.ensembl.org/biomart/martview/
7ee294b9ae51a27f1e7ed96e712c5792?

On Wed, Jun 8, 2016 at 11:33 AM Martin Čech <mar...@bx.psu.edu> wrote:

> This looks like an Ensembl problem, because they are prefixing the
> redirect url with "http://www.ensembl.org/
> <http://www.ensembl.org/galaxy-dev.fmi.ch/tool_runner/biomart?type=text&name=Homo%20sapiens%20genes%20%28GRCh38.p5%29&URL=http://www.ensembl.org/biomart/martview/7ee294b9ae51a27f1e7ed96e712c5792?do_export=1&resultsButton=1>".
> If you just go to http://
> galaxy-dev.fmi.ch/tool_runner/biomart?type=text&name=Homo%20sapiens%20genes%20%28GRCh38.p5%29&URL=http://www.ensembl.org/biomart/martview/7ee294b9ae51a27f1e7ed96e712c5792?do_export=1&resultsButton=1
> <http://www.ensembl.org/galaxy-dev.fmi.ch/tool_runner/biomart?type=text&name=Homo%20sapiens%20genes%20%28GRCh38.p5%29&URL=http://www.ensembl.org/biomart/martview/7ee294b9ae51a27f1e7ed96e712c5792?do_export=1&resultsButton=1>
>  it
> will most probably work.
>
> They might be whitelisting usegalaxy.org to not add prefix, or some other
> bug, I will try contacting them, thank you for the report.
>
> Martin
>
> On Wed, Jun 8, 2016 at 11:19 AM Hans-Rudolf Hotz <h...@fmi.ch> wrote:
>
>> Hi Martin
>>
>> we are still on "15.10" (minor version "2")
>>
>> However, I see the same issues on other public galaxy server which are
>> already on 16.04
>>
>>
>>
>> http://www.ensembl.org/galaxy-dev.fmi.ch/tool_runner/biomart?type=text&name=Homo%20sapiens%20genes%20%28GRCh38.p5%29&URL=http://www.ensembl.org/biomart/martview/7ee294b9ae51a27f1e7ed96e712c5792?do_export=1&resultsButton=1
>>
>>
>>
>> Hans-Rudolf
>>
>>
>> On 06/08/2016 04:36 PM, Martin Čech wrote:
>> > Hello Hans-Rudolf,
>> >
>> > What version of Galaxy are you using? Can you please share a specific
>> > URL you were sent to that returns a 404?
>> >
>> > thanks
>> >
>> > M.
>> >
>> >
>> > On Wed, Jun 8, 2016 at 4:53 AM Hans-Rudolf Hotz <h...@fmi.ch
>> > <mailto:h...@fmi.ch>> wrote:
>> >
>> >     Hi all
>> >
>> >     Please allow me to come back to this old problem:
>> >
>> >     On usegalaxy.org <http://usegalaxy.org>, the tool is now pointing
>> to
>> >     http://www.ensembl.org/biomart/martview (see also:
>> >
>> https://github.com/galaxyproject/galaxy/commit/c49e7803fa1814abd04afb26b54965fb7af612ac
>> >     ) and it seems to work, i.e stuff is sent to usegalaxy.org
>> >     <http://usegalaxy.org>.
>> >
>> >     If I try to do the same on our local galaxy server, I still run
>> into the
>> >     same problem as last November: the requests are not send to Galaxy,
>> but
>> >     end up on the ensembl web page, where they cause a "Error 404 -
>> Page not
>> >     found".
>> >
>> >     Is there anything else, I need to change?
>> >
>> >
>> >     Thank you very much for your help
>> >     Hans-Rudolf
>> >
>> >
>> >
>> >     On 11/17/2015 08:40 AM, Hans-Rudolf Hotz wrote:
>> >      > Hi
>> >      >
>> >      > As you probably know, the central BioMart server is currently
>> >      > unavailable (see: http://www.biomart.org/notice.html). Hence,
>> the
>> >     "Get
>> >      > Data -> BioMart Central server" tool in our local Galaxy
>> installation
>> >      > does not work anymore - well, this is also the case on
>> >     usegalaxy.org <http://usegalaxy.org>.
>> >      >
>> >      >
>> >      > We can easily switch the tool to point to a different Mart
>> >     server, i.e.:
>> >      >
>> >      > Change: <inputs action="http://www.biomart.org/biomart/martview";
>> ....
>> >      >
>> >      > to: <inputs
>> >     action="http://www.ebi.ac.uk/uniprot/biomart/martview"; ....
>> >      >
>> >      >
>> >      > However, we would like to switch to the ensembl Mart server:
>> >      >
>> >      > http://www.ensembl.org/biomart/martview
>> >      >
>> >      >
>> >      > It looks like the ensembl Mart server is nowadays embedded in the
>> >      > ensembl web site, and the requests are not send to Galaxy, but
>> >     end up on
>> >      > the ensembl web page, where they cause a "Error 404 - Page not
>> >     found".
>> >      > Unfortunately, I am not that savvy about the inner works of the
>> >     ensembl
>> >      > web site anymore ;)
>> >      >
>> >      >
>> >      > Has anyone else looked into this problem and found already a
>> >     solution?
>> >      >
>> >      > Thank you very much for any help
>> >      >
>> >      >
>> >      > Hans-Rudolf
>> >      >
>> >      >
>> >     ___________________________________________________________
>> >     Please keep all replies on the list by using "reply all"
>> >     in your mail client.  To manage your subscriptions to this
>> >     and other Galaxy lists, please use the interface at:
>> >     https://lists.galaxyproject.org/
>> >
>> >     To search Galaxy mailing lists use the unified search at:
>> >     http://galaxyproject.org/search/mailinglists/
>> >
>>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to