Hi again,

I have been able to solve this problems thanks to fix commited by nsoranzo
and I installed the package_trinity_2_1_1 correclty. However, when
installing trinity (e4a9e0798360) there is a problem with the edger and
express dependencies. In the trinity's tool_dependencies.xml file these two
packages appear as:

<package name="edger" version="3.12.0">
<package name="express" version="1.5.1">

However, in the tool_dependencies.xml file from these packages they appear
with a different name:

<package name="bioconductor-edger" version="3.12.0">
<package name="eXpress" version="1.5.1">

Therefore, I suppose that Galaxy does not recognize them and they are shown
as Never Installed.

Could you look into this?

Regards,
Jose


2016-06-09 17:09 GMT+02:00 Jose Juan Almagro Armenteros <jjalma...@gmail.com
>:

> Hello,
>
> I am having troubles installing the last version of the tool Trinity. I
> found that I have the same error as this issue (
> https://github.com/galaxyproject/galaxy/issues/1947), so I tried the
> suggested solution. It didn't work, so I posted the error in the issue.
>
> Then, I tried to change the tmp folder to another one in the same
> filesytem (and undoing the previous solution).  Again it didn't work, but
> it gave a different error:
>
>
> File 
> "/steno-internal/projects/galaxy/galaxy-dist/lib/tool_shed/galaxy_install/install_manager.py",
>  line 123, in install_and_build_package_via_fabric
>
>     tool_dependency = self.install_and_build_package( install_environment, 
> tool_dependency, actions_dict )
>
>   File 
> "/steno-internal/projects/galaxy/galaxy-dist/lib/tool_shed/galaxy_install/install_manager.py",
>  line 108, in install_and_build_package
>     initial_download=False )
>
>   File 
> "/steno-internal/projects/galaxy/galaxy-dist/lib/tool_shed/galaxy_install/tool_dependencies/recipe/recipe_manager.py",
>  line 31, in execute_step
>     initial_download=initial_download )
>
>   File 
> "/steno-internal/projects/galaxy/galaxy-dist/lib/tool_shed/galaxy_install/tool_dependencies/recipe/step_handler.py",
>  line 845, in execute_step
>
>     destination_dir=os.path.join( action_dict[ 'destination_directory' ] ) )
>
>   File 
> "/steno-internal/projects/galaxy/galaxy-dist/lib/tool_shed/galaxy_install/tool_dependencies/recipe/step_handler.py",
>  line 864, in move_directory_files
>     shutil.move( source_file, destination_file )
>   File "/usr/lib/python2.7/shutil.py", line 130, in copy2
>     copyfile(src, dst)
>   File "/usr/lib/python2.7/shutil.py", line 82, in copyfile
>     with open(src, 'rb') as fsrc:
>
>
> [Errno 21] Is a directory: 
> '/steno-internal/projects/galaxy/galaxy-dist/tmp/tmp-toolshed-mtd8Exq2w/trinityrnaseq-2.1.1/trinity-plugins/jellyfish'
>
> I am using the Galaxy release *16.01. *Do you know how could I solve this
> problem?
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to