Dear Nicola

I have the version 16.01.
I dont know what is happening because before everything was working
perfectly. I conifgured through the config/auth_conf.xml

<auth>
<authenticator>
        <type>ldap</type>

        <!-- Replacement fields: instances of {email}, {username} and
{password}
             are replaced with the corresponding user's values inside the
             <filter>, <server>, <ldap-options>, <search-fields>,
             <search-filter>, <search-base>, <search-user> and
<search-password>
             elements. -->
        <!-- Filter users for which this authenticator applies. This is a
Python
             expression which is evaluated after field replacement. -->
          <!--   <filter>'{email}'.endswith('@example.com')</filter>-->
        <options>

            <!-- Whether to allow user registration. Possible values are
True,
                 False and Challenge (i.e. allow registration in case of
                 successful authentication). Default is True. -->
            <allow-register>True</allow-register>

            <!-- Whether Galaxy should automatically register users when
they
                 first login. Default is False. -->
            <auto-register>True</auto-register>

            <!-- Whether users are allowed to change their password.
Default is
                 False. -->
<!--        <allow-password-change>False</allow-password-change>
-->

I tried to change relaod again today but still the smae problem.

I have this error/warning when I start sh run.sh command:

home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315:
SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject
Name Indication) extension to TLS is not available on this platform. This
may cause the server to present an incorrect TLS certificate, which can
cause validation failures. For more information, see
https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
  SNIMissingWarning
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120:
InsecurePlatformWarning: A true SSLContext object is not available. This
prevents urllib3 from configuring SSL appropriately and may cause certain
SSL connections to fail. For more information, see
https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning
.


I don't know if ot is because of the SSL certification we installed
recently on apache.

When an old user is trying to loggin it is working because the user is in
the database of Galaxy, but I see  this error or wraning don't know.

galaxy.auth.providers.ldap_ad DEBUG 2016-09-16 14:21:26,902 LDAP
authentication successful
/home/galaxy/galaxy-dist/.venv/lib/python2.7/site-packages/sqlalchemy/sql/default_comparator.py:153:
SAWarning: The IN-predicate on "request_type.id" was invoked with an empty
sequence. This results in a contradiction, which nonetheless can be
expensive to evaluate.  Consider alternative strategies for improved
performance.
  'strategies for improved performance.' % expr)


However if new user is trying to loggin it is saying succeful but in the
web interface it is saying username or password invalid.

galaxy.auth.providers.ldap_ad DEBUG 2016-09-15 17:06:41,776 LDAP
authentication successful
10.38.149.72 - - [15/Sep/2016:17:06:41 +0200] "POST
/user/login?use_panels=True HTTP/1.1" 200 - "
https://galaxy-g.nihs.ch.nestle.com/user/login?use_panels=True&redirect=%2F";
"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.36 (KHTML,
like Gecko) Chrome/49.0.2623.112 Safari/537.36"

Thanks Mohamed

2016-09-15 20:28 GMT+02:00 Nicola Soranzo <nsora...@tiscali.it>:

> Hi Mohamed,
> - what Galaxy release are you using?
> - what LDAP server are you using?
> - how did you configured LDAP auth? remote user or using
> config/auth_conf.xml
>
> Cheers,
> Nicola
>
>
> On 15/09/16 18:27, Mohamed Kassam wrote:
>
>> Dear all
>> I have an issue today, with authentication in our galaxy instance.
>> I restarted our instance and now new user can not be auto register
>> automatically.
>> I am using the ldap of our institute, old user can login but when a new
>> user wants to login it says user or email invalid however I saw on the
>> terminal that ldap authentication is successful.
>>
>> Do you know if someone had the some issue or problem with the the
>> database.
>>
>> Thanks in advance
>>
>> Mohamed
>>
>>
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>>    https://lists.galaxyproject.org/
>>
>> To search Galaxy mailing lists use the unified search at:
>>    http://galaxyproject.org/search/mailinglists/
>>
>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to