Hi all,

While trying to install tools from the toolshed via the browser interface, an 
error keeps appearing and nothing is abled to be installed. Currently using the 
latest version of Galaxy and having tried to install several different tools, 
the following error keeps appearing in the log file.

galaxy.queue_worker DEBUG 2016-11-03 13:08:32,425 Executing toolbox reload on 
'main'
Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 811, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/tools/toolbox/watcher.py", 
line 147, in on_any_event
    self._handle(event)
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/tools/toolbox/watcher.py", 
line 150, in _handle
    self.reload_callback()
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/tools/toolbox/base.py", 
line 78, in <lambda>
    self._tool_conf_watcher = get_tool_conf_watcher( lambda: 
reload_toolbox(app))
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/queue_worker.py", line 56, 
in reload_toolbox
    app.toolbox = _get_new_toolbox(app)
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/queue_worker.py", line 72, 
in _get_new_toolbox
    new_toolbox = tools.ToolBox(tool_configs, app.config.tool_path, app, 
app.toolbox._tool_conf_watcher)
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/tools/__init__.py", line 
110, in __init__
    tool_conf_watcher=tool_conf_watcher
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/tools/toolbox/base.py", 
line 1037, in __init__
    super(BaseGalaxyToolBox, self).__init__(config_filenames, tool_root_dir, 
app, tool_conf_watcher=tool_conf_watcher)
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/tools/toolbox/base.py", 
line 69, in __init__
    self._init_integrated_tool_panel( app.config )
  File 
"/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/tools/toolbox/integrated_panel.py",
 line 36, in _init_integrated_tool_panel
    self._load_integrated_tool_panel_keys()
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/tools/toolbox/base.py", 
line 368, in _load_integrated_tool_panel_keys
    tree = parse_xml( self._integrated_tool_panel_config )
  File "/mnt/sdd1/nondocker_galaxy/galaxy/lib/galaxy/util/__init__.py", line 
211, in parse_xml
    root = tree.parse( fname, parser=ElementTree.XMLParser( 
target=DoctypeSafeCallbackTarget() ) )
  File "/usr/lib64/python2.7/xml/etree/ElementTree.py", line 656, in parse
    parser.feed(data)
  File "/usr/lib64/python2.7/xml/etree/ElementTree.py", line 1642, in feed
    self._raiseerror(v)
  File "/usr/lib64/python2.7/xml/etree/ElementTree.py", line 1506, in 
_raiseerror
    raise err
ParseError: not well-formed (invalid token): line 44, column 71

Is there an XML or configuration file which needs to be changed for this to 
work? Not sure how to proceed.

Thanks!
Miuki
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to